PML error

Thread index  |  Previous thread  |  Next thread  |  Start a new discussion

RSS FeedRSS feed   |   Email notificationsTurn on email notifications   |   13 Replies   Last post: June 13, 2014 2:15am UTC
Yevgeniy Davletshin

Yevgeniy Davletshin

March 11, 2012 6:20pm UTC

PML error

Hi all,

Can someone point me what I do wrong?
I tried to repeat Scattering from plasmonic nanosphere model, so I have Au sphere + Air domain (sphere) +PML/ABC domain (sphere).

When I defining PML as spherical type I'm getting error that Comsol could not find any spherical or cylindrical regions.

Attachments:   PML error.tiff  

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Alexander Kuznetsov

Alexander Kuznetsov

March 12, 2012 4:53pm UTC in response to Yevgeniy Davletshin

Re: PML error

Make sure you have correct center coordinate in PML's settings

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Yevgeniy Davletshin

Yevgeniy Davletshin

March 12, 2012 5:48pm UTC in response to Alexander Kuznetsov

Re: PML error

Any examples?

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Alexander Kuznetsov

Alexander Kuznetsov

March 12, 2012 6:04pm UTC in response to Yevgeniy Davletshin

Re: PML error

Radome antenna is a good one. Also uploading your model might help :)

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Yevgeniy Davletshin

Yevgeniy Davletshin

March 12, 2012 6:17pm UTC in response to Alexander Kuznetsov

Re: PML error

Ok
Hear is a sample.
If you try to go to Study -> Solve config -> and reach Show Default Solver it will give me instant error.

Thanks for help.

Attachments:   sample.mph  

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Alexander Kuznetsov

Alexander Kuznetsov

March 12, 2012 6:54pm UTC in response to Yevgeniy Davletshin

Re: PML error

Looks like a bug to me. Your settings are all fine.

To make it working, change "units" under geometry to meters. Then scale you sphere back to nanometers by multiplying all the dimensions by 1E-9. After doing that, default solver can be created.

I'd write to support. If you do, please let us know their answer. Thanks!

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Yevgeniy Davletshin

Yevgeniy Davletshin

March 12, 2012 7:09pm UTC in response to Alexander Kuznetsov

Re: PML error

Thank you for help Alex.

You are right about nanometer BUG.

I'll contact support and will update this thread after they will reply me.

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Yevgeniy Davletshin

Yevgeniy Davletshin

March 13, 2012 10:34am UTC in response to Yevgeniy Davletshin

Re: PML error

Hi Yevgeniy,

Thanks for reporting this issue. It is a bug, occurring when using [nm] and
sometimes [um] together with spherical or cylindrical PMLs. The fix will be
included in our next release. In the meantime, the easiest workaround is to
set up your geometry in [m] instead.

The problem could technically arise in acoustics models as well, but those
only very rarely use such small units.

I agree that it would make sense to report this in a knowledge base entry.
I will create one as soon as I get the chance.

Best regards,

Linus
COMSOL Support

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Alexander Kuznetsov

Alexander Kuznetsov

March 13, 2012 6:15pm UTC in response to Yevgeniy Davletshin

Re: PML error

Great, thanks for sharing!

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Kyle Chen

Kyle Chen

March 19, 2012 8:51pm UTC in response to Alexander Kuznetsov

Re: PML error

Thanks for pointing out this bug. I have the same problem in my model and I cannot figure out why and try to post on this forum to look for the solution. Now, I know I can do nothing about this bug but only change the unit setting. I hope this problem will be solved in the next version.

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Evelyn Livermore

Evelyn Livermore

May 20, 2012 11:22am UTC in response to Yevgeniy Davletshin

Re: PML error


Hi Yevgeniy,

Thanks for reporting this issue. It is a bug, occurring when using [nm] and
sometimes [um] together with spherical or cylindrical PMLs. The fix will be
included in our next release. In the meantime, the easiest workaround is to
set up your geometry in [m] instead.

The problem could technically arise in acoustics models as well, but those
only very rarely use such small units.




I'm getting the same error, but with [mm]. I am using MF-Solid Mechanics. The PMLs are in the Solid Mechanics physics. Should I correct to [m] instead? or might there be something other wrong with my model.

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Nishtha Chopra

Nishtha Chopra

December 24, 2013 2:27pm UTC in response to Yevgeniy Davletshin

Re: PML error

I am having the same error, my dimensions have to be in mm. However, they look weired when I try them in meters. I am beginner so don't have much knowledge about the software. It would be great to have some suggestions.

I am also attaching my file for more information.

Regards,

Nishtha

Attachments:   3D_blood.mph  

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

 Meng

Meng

June 12, 2014 3:11pm UTC in response to Yevgeniy Davletshin

Re: PML error

yes, it is really a bug. set the unit to [m], the error disappear

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

 Meng

Meng

June 13, 2014 2:15am UTC in response to Yevgeniy Davletshin

Re: PML error

I found that if the PML layer is not a standard rectangle, circle or circular ring then comsol always show could not find any spherical or cylindrical ...

In my example, the outside region is a bit arbitrary, and the region can not be set as a PML layer.

I was wondering if PML layer mus be a standard rectangle, circle or circular ring region?

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse


Rules and guidelines