Problems with boundary layer meshing

Topics: Mesh, CFD, 4.2a

Thread index  |  Previous thread  |  Next thread  |  Start a new discussion

RSS FeedRSS feed   |   Email notificationsTurn on email notifications   |   1 Reply   Last post: June 6, 2013 8:18am UTC
John McTernan

John McTernan

February 10, 2013 2:24pm UTC

Problems with boundary layer meshing

I am trying to mesh a k-epsilon model and cannot generate a boundary layer mesh. My model has a very narrow region and I expect that that is the problem area. The error I get most often is: Could not shift boundary node at all. The first screen shot attached is a view of the narrow region. The second shot shows the internals.

Attachments:   mesh 1.png   mesh 2.png  

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Yoav Matia

Yoav Matia

June 6, 2013 8:18am UTC in response to John McTernan

Re: Problems with boundary layer meshing

Hi there
here is the solution for you:

Prelude:
I to have encountered that same error so many times when i modeled 3D geometries yet almost never when modeling 2D geometries. Why?
COMSOL is trying to patch over the sharp corner diagonally in order to better/more smoothly mesh over the geometry in a way that will enable better representation of flow gradients over a corner.
all that is excellent and another reason why i have so much appreciation for COMSOL developers as they are actual Mathematics/Engineering/Physics professionals.
however, the problem is that doing this sort of "patching" is quite simple in 2D but very difficult in 3D, unless the geometry is very specific and of the kind that will not bring the meshing algorithm into collapse upon itself (due to impossible clustering of such elements).

(remainder: the higher the physics-gradient present at geometrical location, the denser the mesh you will need to "capture" and depict that phenomena using FEM, for reasons related to Element order).

Solution:
all you need to do is:
Ver 4.2a ==> uncheck the split boundary layer check box (see pictures attached)
Ver 4.3B==> choose the trimming option from the drop menu /Engineering

works for me every time :)

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse


Rules and guidelines