Not able to properly use remesh feature in multiphysics stationary simulation

Thread index  |  Previous thread  |  Next thread  |  Start a new discussion

RSS FeedRSS feed   |   Email notificationsTurn on email notifications   |   2 Replies   Last post: February 23, 2013 1:53pm UTC
nde

nde

February 21, 2013 7:50pm UTC

Not able to properly use remesh feature in multiphysics stationary simulation

Hi,

I have simulated a steel specimen that becomes deformed due to bending. For that, I use the solid mechanics interface in a stationary study. Parametrizing the magnitude of bending also works. Overall, it works as expected.

I have also simulated an electromagnet by using the magnetic fields interface and specifying a DC external current density in a stationary study. That also works well.

I have attempted to include both of them in the same model, where I want the specimen to be deformed, remeshed, and that new mesh be used in the magnetic fields stationary study. Oh, and I want to parametrize the magnitude of bending, such that the sequence of operations is:

1. Deform 1 mm relative to rest position (calculate from initial mesh)
2. Remesh
3. Calculate DC magnetic fields (using remeshed geometry )

4. Deform 2 mm relative to rest position (calculate from initial mesh)
5. Remesh
6. Calculate DC magnetic fields using remeshed geometry

and so on...

So far, I have managed to remesh by using ALE and the model works without errors. However, I have a hunch that the magnetic fields interface only takes into account the initial mesh. As a result, the magnetic field distribution remains the same, and the only reason why it follows the shape of the deformed specimen in the plot, is because I have added "Deformation" as an addition to the plot. Could this be the case, what do you think?

I have been struggling with this for quite a while. Any ideas/suggestions would be highly appreciated. Thanks in advance for your time,

Kind Regards,
Orfeas

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

nde

nde

February 23, 2013 12:40am UTC in response to nde

Re: Not able to properly use remesh feature in multiphysics stationary simulation

Anyone?

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Ivar Kjelberg

Ivar Kjelberg

February 23, 2013 1:53pm UTC in response to nde

Re: Not able to properly use remesh feature in multiphysics stationary simulation

Hi

but one should be able to combine ALE, solid + MF in one model, define the ALE everywhere, define SOLID for the solid domains intha middle of the air and the magnet, and the MF everywhere.

if ALE is first (where it should be) it will disable for the region of "solid", as this has some sort of ALE already inlcuded.

then you can solve for u (displacements), and Vm or A the magnetic potential (in 2D respectively 3D) together and the magnet will notice the change in distance to the solid

--
Good luck
Ivar

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse


Rules and guidelines