Scattering Model Doesn't Compute

Thread index  |  Previous thread  |  Next thread  |  Start a new discussion

RSS FeedRSS feed   |   Email notificationsTurn on email notifications   |   2 Replies   Last post: June 13, 2014 4:26pm UTC
Daniel Frantz

Daniel Frantz

June 12, 2014 6:11pm UTC

Scattering Model Doesn't Compute

Hello,
I'm trying to model the scattering effects of light off of a thin box. I used the model example "Optical Scattering Off a Gold Nanosphere" as a reference model. " I've tried a few approaches when modeling the system, and I keep getting the error "Undefined value found - Detail: NaN or Inf found when solving linear system using SOR. - Feature: Stationary Solver 1 (sol3/s1)". I don't know where exactly the undefined value is coming from. How can I avoid/fix this error?

Thanks,
Daniel Frantz

Attachments:   Comsol Scattering 3.mph  

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Sergei Yushanov

Sergei Yushanov
Certified Consultant
AltaSim Technologies, LLC

June 13, 2014 12:46pm UTC in response to Daniel Frantz

Re: Scattering Model Doesn't Compute

Daniel,

You are getting this error message because mesh element size is larger than wavelength. You defined appropriate parameter for mesh size (h_max) but didn't use it for mesh generation.

Attached is your modified model which solves the problem without getting error. Note that at the frequency you specified computation requires ~40G of RAM.

Regards,
Sergei

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Daniel Frantz

Daniel Frantz

June 13, 2014 4:26pm UTC in response to Sergei Yushanov

Re: Scattering Model Doesn't Compute

Sergei,

Thank you! I've got the model running as intended. You have been very helpful.

Regards,
Daniel Frantz

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse


Rules and guidelines