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Introduction
The AC/DC Module is used by engineers and scientists to understand, predict, and 
design electric and magnetic fields in statics and low-frequency applications. 
Simulations of this kind result in more powerful and efficient products and 
engineering methods. It allows its users to quickly and accurately predict 
electromagnetic field distributions, electromagnetic forces, and power dissipation in 
a proposed design. Compared to traditional prototyping, COMSOL helps to lower 
costs and can evaluate and predict entities that are not directly measurable in 
experiments. It also allows the exploration of operating conditions that would 
destroy a real prototype or be hazardous.

The AC/DC Module includes stationary and dynamic electric and magnetic fields in 
two-dimensional and three-dimensional spaces along with traditional circuit-based 
modeling of passive and active devices. All modeling formulations are based on 
Maxwell’s equations or subsets and special cases of these together with material laws 
like Ohm’s law for charge transport. The modeling capabilities are accessed via a 
number of predefined user interfaces, referred to as AC/DC interfaces, which allow 
you to set up and solve electromagnetic models. The AC/DC interfaces cover 
electrostatics, DC current flow, magnetostatics, AC and transient current flow, AC 
and transient magnetodynamics, and AC electromagnetic (full Maxwell) formulations.

Under the hood, the AC/DC interfaces formulate and solve the differential form of 
Maxwell’s equations together with initial and boundary conditions. The equations are 
solved using the finite element method with numerically stable edge element 
discretization in combination with state-of-the-ar t algorithms for preconditioning and 
solution of the resulting sparse equation systems. The results are presented in the 
graphics window through predefined plots of electric and magnetic fields, currents 
and voltages or as expressions of the physical quantities that you can define freely, 
and derived tabulated quantities (for example resistance, capacitance, inductance, 
electromagnetic force, and torque) obtained from a simulation.

The work flow in the module is straightforward and is described by the following 
steps: define the geometry, select materials, select a suitable AC/DC interface, define 
boundary and initial conditions, define the finite element mesh, select a solver, and 
visualize the results. All these steps are accessed from the COMSOL Desktop. The 
solver step is usually carried out automatically using the default settings, which are 
already tuned for each specific interface.
Introduction | 5
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The AC/DC Module Model Library describes the AC/DC interfaces and the available 
features using tutorial and benchmark examples for the different formulations. The 
library contains models for industrial equipment and devices, tutorial models, and 
benchmark models for verification and validation of the AC/DC interfaces. See 
“Opening the Model Library” on page 16 to star t exploring now.

This guide is intended to give you a jump star t to your modeling work. It contains 
examples of the typical use of the module, a list of all the AC/DC interfaces including 
a short description for each interface, and a tutorial example that introduces the 
modeling workflow.

The Use of the AC/DC Module
The AC/DC Module can model electric, magnetic, and electromagnetic fields in 
statics and low-frequency applications. The latter means that it covers the modeling 
of devices that are up to about 0.1 electromagnetic wavelengths in size. Thus, it can 
be used to model nanodevices up to optical frequencies or for human size devices 
operated at frequencies up to 10 MHz.

AC/DC simulations are frequently used to extract circuit parameters. Figure 1 shows 
the electric potential and the magnetic flux lines for a micro-scale square inductor, 
used for LC bandpass filters in microelectromechanical systems (MEMS). A DC 
voltage is applied across the electrically conducting square shaped spiral, resulting in 
6 | Introduction
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an electric current flow that in turn generates a magnetic field through and around 
the device.

Figure 1: Electric potential distribution and magnetic flux lines for a MEMS inductor.

The distribution and strength of electric and magnetic fields arising from applied 
current and voltage can be translated into resistance, capacitance, and inductance 
values for an equivalent circuit model that is easy to understand and analyze from 
both qualitative and quantitative perspectives. This kind of understanding in terms of 
a simplified model is usually the first step when creating or improving a design.

Another common use of this module is to predict forces and motion in electric 
motors and actuators of a wide range of scales.

In the next three figures (Figure 2, Figure 3, and Figure 4), the dynamics of a magnetic 
brake is shown. The brake consists of a disc of conductive material and a permanent 
magnet. The magnet generates a constant magnetic field, in which the disc is rotating. 
Introduction | 7
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When a conductor moves in a magnetic field it induces currents, and the Lorentz 
forces from the currents counteracts the spinning of the disc.

Figure 2: The eddy current magnitude and direction in the spinning disc of a magnetic brake.

The braking torque is computed from the magnetic flux and eddy current 
distributions. It is then fed into a rigid body model for the dynamics of the spinning 
disc that is solved simultaneously with the electromagnetic model. 
8 | Introduction
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Figure 3: The time evolution of the braking torque.
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Figure 4: The time evolution of the angular velocity.

The AC/DC Module includes a vast range of tools to evaluate and export results, for 
example, the evaluation of force, torque, and lumped circuit parameters like 
resistance, capacitance, inductance, impedance, and scattering matrices 
(S-parameters). Lumped parameters can also be exported in the Touchstone file 
format.

The combination of fully distributed electromagnetic field modeling and simplified 
circuit based modeling is an ideal basis for design, exploration, and optimization. 
More complex system models can be exploited using circuit-based modeling while 
maintaining links to full field models for key devices in the circuit allowing for design 
innovation and optimization on both levels.

The AC/DC Module Interfaces
The AC/DC physics interfaces are based upon Maxwell’s equations or subsets and 
special cases of these together with material laws. Different subsets of Maxwell’s 
equations in combination with special material laws result in different electric, 
magnetic, or electromagnetic formulations. In the module, these laws of physics are 
10 | Introduction
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translated by the AC/DC interfaces to sets of partial differential equations with 
corresponding initial and boundary conditions.

An AC/DC interface defines a number of features. Each feature represents an 
operation that describes a term or condition in the underlying Maxwell-based 
formulation. Such a term or condition may be defined in a geometric entity of the 
model, such as a domain, boundary, edge (for 3D models), or point. 

Figure 5 on the next page uses the Capacitor Tunable model (found in the AC/DC 
Module Model Library) to show the Model Builder window and the settings window 
for the selected Charge Conservation 1 feature node. The Charge Conservation 1 
node also adds the terms to the model equations to a selected geometrical domain 
representing the electrostatics domain in the model. 

Furthermore, and shown in Figure 5, the Charge Conservation 1 node may link to 
the Materials node to obtain physical properties such as relative permittivity, in this 
case the relative permittivity of a user-defined dielectric. The properties, defined by 
the Dielectric material node, may be functions of the modeled physical quantities, 
such as temperature. In the same fashion, the Zero Charge 1 boundary condition 
feature adds the natural boundary conditions that limit the Electrostatics domain. 
Introduction | 11
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Figure 5: The Model Builder window (to the left), and the Charge Conservation 1 settings window for the 
selected feature node (to the right). The Equation section in the settings window shows the model 
equations and the terms added to the model equations by the Charge Conservation 1 node. The added 
terms are underlined with a dotted line. The text also explains the link between the Dialectric node and 
the values for the Relative permittivity.

The AC/DC Module includes a number of AC/DC interfaces ( ) for different types 
of electric and/or magnetic modeling. Figure 6 includes the AC/DC interfaces as well 
12 | Introduction
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as those under the Heat Transfer folder, which contains the Induction Heating 
interface. Also see “Physics List by Space Dimension and Preset Study Type” on page 
15. A brief overview of the AC/DC interfaces follows.

Figure 6: The AC/DC Module physics as displayed in the Model Wizard. Note that this is for 3D models. 
The Rotating Machinery, Magnetic interface is also available in 2D.

E L E C T R O S T A T I C S

The Electrostatics interface ( ) solves a charge conservation equation for the 
electric potential given the spatial distribution of the electric charge. It is used 
primarily to model charge conservation in dielectrics under static conditions. The 
interface applies also under transient conditions but then it is usually combined with 
a separate transport model for single species or multispecies charge transport. Such 
transport models can be found in the Chemical Reaction Engineering Module and in 
the Plasma Module. Some typical applications that are simulated in the interface are 
capacitors, dielectric sensors, and bushings for high voltage DC insulation. 

E L E C T R I C  C U R R E N T S

The Electric Currents interface ( ) is used to model DC, AC, and transient electric 
current flow in conductive and capacitive media. The interface solves a current 
conservation equation for the electric potential. Some examples of its use are 
Introduction | 13
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designing busbars for DC current distribution, computing current distributions in 
impressed current cathodic corrosion protection, and designing AC capacitors.

E L E C T R I C  C U R R E N T S ,  S H E L L

The Electric Currents, Shell interface ( ) is available in 2D, 2D axisymmetric, and 
3D geometries. It is used to model DC, AC, and transient electric current flow 
confined to conductive and capacitive thin current-conducting shells of fixed or 
varying thickness. The interface solves a boundary current conservation equation for 
the electric potential. Modeling ground return current flow in the hull of a ship or in 
the body of a car are two examples of simulations that can be performed using this 
interface.

M A G N E T I C  F I E L D S

The Magnetic Fields interface ( ) solves Ampère’s law for the magnetic vector 
potential. It is used to model magnetostatics, AC, and transient magnetodynamics. 
Magnets, magnetic actuators, electric motors, transformers, induction based 
nondestructive testing, and eddy current generation are typical applications for this 
interface. It supports both linear media and media with magnetic saturation.

M A G N E T I C  A N D  E L E C T R I C  F I E L D S

The Magnetic and Electric Fields interface ( ) is used to model magnetostatics and 
AC magnetodynamics. It solves Ampère’s law for the magnetic vector potential 
together with a current conservation equation for the electric potential. The 
application areas are mostly the same as for the Magnetic Fields interface. The 
addition of the electric potential makes it more flexible as also electric boundary 
conditions are available.

M A G N E T I C  F I E L D S ,  N O  C U R R E N T S

The Magnetic Fields, No Currents interface ( ) is used to efficiently model 
magnetostatics in current free regions, for example, when designing permanent 
magnet-based devices. It solves a magnetic flux conservation equation for the 
magnetic scalar potential. The interface supports both linear media and media with 
magnetic saturation.

E L E C T R I C A L  C I R C U I T

The Electrical Circuit interface ( ) has the equations to model electrical circuits 
with or without connections to a distributed fields model, solving for the voltages, 
14 | Introduction
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currents, and charges associated with the circuit elements. Circuit models can contain 
passive elements like resistors, capacitors, and inductors as well as active elements 
such as diodes and transistors.

R O T A T I N G  M A C H I N E R Y,  M A G N E T I C

The Rotating Machinery, Magnetic interface ( ) combines the magnetic fields 
(magnetic vector potential) and magnetic fields, no currents (scalar magnetic 
potential) formulations with a selection of predefined frames for prescribed rotation 
or rotation velocity—it shares most of its features with the Magnetic Fields interface. 
This interface requires that the geometry is created as an assembly from individual 
parts for the rotor and stator.

I N D U C T I O N  H E A T I N G

The Induction Heating multiphysics interface ( ) combines all features from the 
Magnetic Fields interface in the time-harmonic formulation with the Heat Transfer 
interface to model induction and eddy current heating. The predefined interaction 
adds the electromagnetic losses from the magnetic field as a heat source. This 
interface is based on the assumption that the magnetic cycle time is short compared 
to the thermal time scale (adiabatic assumption).

Physics List by Space Dimension and Preset Study Type
The table below list the interfaces available specifically with this module in addition 
to the COMSOL Multiphysics basic license.

PHYSICS ICON TAG SPACE DIMENSION PRESET STUDIES

  AC/DC

Electrostatics* es all dimensions stationary; time dependent

Electric Currents* ec all dimensions stationary; frequency domain; 
time dependent; small signal 
analysis, frequency domain

Electric Currents - Shell ecs 3D, 2D, 2D 
axisymmetric

stationary; frequency domain; 
time dependent; small signal 
analysis, frequency domain

Magnetic Fields* mf 3D, 2D, 2D 
axisymmetric

stationary; frequency domain; 
time dependent; small signal 
analysis, frequency domain; 
coil current calculation
Introduction | 15
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Opening the Model Library
To open an AC/DC Module Model Library model, select View > Model Library  from 
the main menu in COMSOL Multiphysics. In the Model Library window that opens, 
expand the AC/DC Module folder and browse or search the contents. Click Open 

Model and PDF to open the model in COMSOL Multiphysics and a PDF to read 
background theory about the model including the step-by-step instructions to build 
it. The MPH-files in the COMSOL model libraries can have two formats—Full 
MPH-files or Compact MPH-files.

• Full MPH-files, including all meshes and solutions. In the Model Library these 
models appear with the  icon. If the MPH-file’s size exceeds 25MB, a tip with 
the text “Large file” and the file size appears when you position the cursor at the 
model’s node in the Model Library tree.

• Compact MPH-files with all settings for the model but without built meshes and 
solution data to save space on the DVD (a few MPH-files have no solutions for 
other reasons). You can open these models to study the settings and to mesh and 
re-solve the models. It is also possible to download the full versions—with meshes 
and solutions—of most of these models through Model Library Update. In the 
Model Library these models appear with the  icon.

The next section uses a model from the Model Library. Go to “Tutorial Example: 
Modeling a 3D Inductor” to get star ted.

Magnetic and Electric Fields mef 3D, 2D, 2D 
axisymmetric

stationary; frequency domain; 
small signal analysis, frequency 
domain

Magnetic Fields, No Currents mfnc all dimensions stationary; time dependent

Rotating Machinery, Magnetic rmm 3D, 2D stationary; time dependent

Electrical Circuit cir Not space 
dependent

stationary; frequency domain; 
time dependent

 Electromagnetic Heating

Induction Heating ih 3D, 2D, 2D 
axisymmetric

stationary; frequency domain; 
time dependent; frequency 
stationary; frequency transient

* This is an enhanced interface, which is included with the base COMSOL package but has added 
functionality for this module.

PHYSICS ICON TAG SPACE DIMENSION PRESET STUDIES
16 | Introduction
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Tutorial Example: Modeling a 3D Inductor
Inductors are used in many applications for low-pass filtering or for impedance 
matching of predominantly capacitive loads. They are used in a wide frequency range 
from near static up to several MHz. An inductor usually has a magnetic core to 
increase the inductance, while keeping its size small. The magnetic core also reduces 
the electromagnetic interference with other devices as the magnetic flux tends to 
stay within it. Because there are only crude analytical or empirical formulas available 
to calculate impedances, computer simulations or measurements are necessary 
during the design stage. In general, inductor modeling is more complex than 
modeling resistors and capacitors but similar principles apply. Using an external CAD 
software program to design and draw the model, the geometry is imported into the 
AC/DC Module for static and frequency domain analysis. The inductor geometry is 
shown in Figure 7.

Figure 7: The inductor geometry.

First a magnetostatic simulation is performed to get the DC inductance. At low 
frequencies capacitive effects are negligible. A relevant equivalent circuit model is an 
ideal inductor in a series with an ideal resistor. The inductance and the resistance are 
both computed in the magnetostatic simulation. At a high frequency, capacitive 

core

feed gap

cu winding

96 mm
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effects become significant. The equivalent circuit model involves connecting an ideal 
capacitor in parallel with the DC circuit. The circuit parameters are obtained by 
analyzing the frequency dependent impedance obtained from a frequency domain 
simulation. In this tutorial, the AC analysis is done up to the point when the frequency 
dependent impedance is computed.

These step-by-step instructions guide you through the detailed modeling of an 
inductor in 3D. The module also has a physics interface to model electrical circuits, 
which is detailed in the magnetostatic part of this model. The first step is to perform 
a DC simulation.

MODEL WIZARD

1 Double-click the COMSOL Multiphysics icon on the desktop.

2 In the Model Wizard, click the 3D button and click Next .

3 In the Add Physics tree under AC/DC, select Magnetic Fields (mf) .

4 Click Add Selected  then click Next .

5 In the Studies tree, select Preset Studies>Stationary .

6 Click Finish .

GEOMETRY 1

The main geometry is imported from a file. Air domains are typically not part of a 
CAD geometry, so these are added to the model. For convenience, three additional 
domains are defined in the CAD file and then used to define a narrow feed gap 
where an excitation is applied.

Import 1
1 Under Model 1, right-click Geometry 1  and select Import .

2 In the settings window under Import, click Browse. Then navigate to your COMSOL 
Multiphysics installation folder, locate the subfolder 
ACDC_Module\Inductive_Devices_and_Coils, select the file inductor_3d.mphbin and click 
Open.
18 | Tutorial Example: Modeling a 3D Inductor



acdc_introduction.book  Page 19  Monday, April 23, 2012  6:26 PM
Note: The location of the files used in this 
exercise varies based on the installation. For 
example, if the installation is on your hard 
drive, the file path might be similar to 
C:\Program Files\COMSOL43\models\. 

3 Click Import.

Sphere 1 
1 In the Model Builder, right-click Geometry 1  

and choose Sphere .

2 Go to the Sphere settings window. Under Size 
and Shape in the Radius field, enter 0.2.

3 Click to expand the Layers section. In the 
associated table, under Thickness enter 0.05.

4 Click the Build All  button.

Form Union

1 In the Model Builder under Geometry 1, click 
Form Union .

2 In the Finalize settings window, click Build 
All .

3 On the Graphics window toolbar, click the 
Zoom Extents  button and then the 
Wireframe Rendering  button.
Tutorial Example: Modeling a 3D Inductor | 19
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The geometry should match this figure.

DEFINITIONS - SELECTIONS

Use the Selection feature available under the Definitions node to make the set up of 
materials and physics easier. Star t by defining the domain group for the inductor 
winding and continue by adding other useful selections. These steps illustrate how to 
set up the Explicit nodes and rename the geometric selections accordingly. 

1 In the Model Builder under Model 1, right-click Definitions  and choose 
Selections>Explicit . 

2 Repeat Step 1 and add a total of six (6) 
Explicit nodes . Or right-click the first 
Explicit node and select Duplicate . 
20 | Tutorial Example: Modeling a 3D Inductor
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The following steps are done one at a time for each node using the table below. 

3 In the Model Builder click an Explicit node  to open its settings window. 

4 In the settings window under Geometric Scope, select Domain from the Geometric entity 
level list. Use the table as a guide, and in the Graphics window, select the domains as 
indicated. Then press F2 and rename the node. 

Note: There are many ways to select geometric entities. When you know the domain 
to add, such as in this exercise, you can click the Paste Selection button  and enter the 
information in the Selection field. In this example for the Explicit 1 node, enter 7,8,14 
in the Paste Selection window. For more information about selecting geometric entities 
in the Graphics window, see the COMSOL Multiphysics User’s Guide.

5 After renaming all the nodes under Definitions, the sequence of nodes should match 
this figure. 

DEFAULT NODE NAME SELECT THESE DOMAINS NEW NAME FOR THE NODE

Explicit 1 7, 8, and 14 Winding

Explicit 2 9 Gap

Explicit 3 6 Core

Explicit 4 1–4 and 10–13 Infinite Elements

Explicit 5 1–6 and 9–13 Non-conducting

Explicit 6 5,6, and 9 Non-conducting without IE
Tutorial Example: Modeling a 3D Inductor | 21
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DEFINITIONS - INFINITE ELEMENTS

Use the Infinite Element feature available under the Definitions node to emulate an 
infinite open space surrounding the inductor. The infinite element coordinate scaling 
is recognized by any physics interface supporting it - other physics interfaces are 
automatically disabled in the infinite element domains.

1 In the Model Builder under Model 1, right-click Definitions  and choose Infinite Element 
Domain . 

2 Go to the Infinite Elements settings window. Under Domain Selection select Infinite 
Elements from the Selection list.

3 Under Geometry from the Type list, select Spherical.

MATERIALS

Now define the material settings for the different parts of the inductor. Use the 
Selections defined in the previous section.

Copper
1 From the main menu, select View>Material Browser .

2 Go to the Material Browser. In the Materials tree 
under AC/DC, right-click Copper and choose  
Add Material to Model from the menu. 
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3 In the Model Builder, click Copper. 

4 Go to the Material settings window. Under 
Geometric Entity Selection select Winding from 
the Selection list.

Air
1 Go to the Material Browser. In the Materials 

tree under Built-In right-click Air and choose 
 Add Material to Model from the menu.

2 In the Model Builder, click Air.

3 Go to the Material settings window. Under 
Geometric Entity Selection select 
Non-conducting from the Selection list.

USER-DEFINED MATERIAL 3

The core material is not included in the material library so it is entered as a 
user-defined material.

1 In the Model Builder, right-click Materials  and 
choose Material . 

2 Go to the Material settings window. Under 
Geometric Entity Selection select Core from the 
Selection list.
Tutorial Example: Modeling a 3D Inductor | 23
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3 Under Material Contents in the table, enter these settings in the Value column:

- 0 for the Electrical conductivity

- 1 for the Relative permittivity

- 1e3 for the Relative permeability

4 Press F2 and choose Rename . Go to the Rename Material 
dialog box and enter Core in the New name field.

5 Click OK. The node sequence under Materials should match 
the figure to the right.

To view the Identifier (mat1, mat2, mat3) next to the material node name, select 
View>Model Builder Node Label and select one of the options. This changes what 
combinations of labels are displayed in the Model Builder next to each node.
24 | Tutorial Example: Modeling a 3D Inductor
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MAGNETIC FIELDS (MF)

The model is solved everywhere except in the feed gap region. By keeping this void, 
its default boundary conditions support surface currents closing the current loop. In 
inductor modeling it is crucial to respect current conservation as this is a law of 
nature (Ampère’s law).

1 In the Model Builder under Model 1, click Magnetic Fields .

2 In the Magnetic Fields settings window, select domains 1–8 
and 10–14 only (all domains except 9). Or click the Paste 
Selection button  and enter 1–8, 10–14 in the Selection 
field.

Single-Turn Coil Domain 1 and Boundary Feed 1
A dedicated feature is added for the solid copper winding of the inductor. This 
feature makes it easier to excite the model in various ways.

1 Right-click Magnetic Fields and choose the domain setting Single-Turn Coil Domain .

2 In the Single-Turn Coil Domain settings window, under Domain Selection, choose Winding 
from the Selection list.

3 Right-click Single-Turn Coil Domain 1 and at the boundary level choose Boundary Feed .

4 In the Boundary Feed settings window, to the right of the Boundary Selection list, click the 
Clear Selection button . 

5 Click the Paste Selection button  and enter 58 in the Selection field. Click OK.

Ground 1
1 In the Model Builder, right-click Single-Turn Coil Domain 1 and choose the boundary 

condition Ground .

2 In the Ground settings window, to the right of the Boundary Selection list, click the Clear 
Selection button . 

3 Click the Paste Selection button  and enter 79 in the Selection field. Click OK.

The node sequence under Magnetic Fields should at this 
point match the figure to the right.
Tutorial Example: Modeling a 3D Inductor | 25



acdc_introduction.book  Page 26  Monday, April 23, 2012  6:26 PM
MESH 1

The steep radial scaling of the infinite elements region requires a swept mesh to 
maintain a reasonably effective element quality.

Free Triangular 1 and Size
1 In the Model Builder under Model 1, 

right-click Mesh 1  and choose More 
Operations>Free Triangular .

2 Select Boundaries 9–12, 68, 69, 73, and 
76 only. Or click the Paste Selection 
button  and enter 9–12, 68, 69, 73, 76 
in the Paste Selection field. 

3 In the Model Builder under Mesh 1, click 
Size . In the Size settings window under 
Element Size, click the Predefined button. 
From the list select Coarser.

4 Click to expand the Element Size Parameters section. In the Minimum element size field, 
enter 0.005. 

5 In the Model Builder, right-click Free Triangular 1  and select Build Selected . 

Swept 1 and Distribution 1
1 Right-click Mesh 1  and choose Swept .

2 Go to the Swept settings window. Under Domain Selection: 

- From the Geometric entity level list, select Domain.

- From the Selection list, select Infinite Elements. 
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3 Right-click Swept 1  and choose 
Distribution .

4 Go to the Distribution settings window. 
Under Distribution in the Number of elements 
field, enter 4.

5 Click Build Selected .

Free Tetrahedral 1
1 Right-click Mesh 1  and choose Free 

Tetrahedral .

2 In the Model Builder, right-click Free 
Tetrahedral 1  and choose Build Selected .

The final node sequence under Mesh should 
match the figure.

STUDY 1

The magnetostatic model is now ready to solve.

1 In the Model Builder, right-click Study 1  and choose Compute .

RESULTS

Magnetic Flux Density 
The default plot group shows the magnetic flux density norm. At this point it is 
important to consider whether the results make sense and to try and detect any 
modeling errors.
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DATA SETS AND SELECTIONS

By adding Selections and adjusting the Data Sets under the Results node you can 
create more interesting plots.

1 In the Model Builder, expand the Results>Data 
Sets node. Right-click Solution 1  and choose 
Duplicate . 

2 Right-click Solution 2  and choose Add 
Selection . 

3 Go to the Selection settings window. Under 
Geometric entity selection:

- From the Geometric entity level list, select 
Domain. 

- From the Selection list, select Winding.

4 Right-click Solution 1  and choose Duplicate .
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5 Right-click Solution 3  and choose Add Selection . A 
Selection node is added to the Model Builder.

6 Go to the Selection settings window. Under Geometric Entity 
Selection:

- From the Geometric entity level list, select Domain. 

- From the Selection list, select Core.

3D Plot Group 2
1 In the Model Builder, right-click Results  and choose 3D Plot Group .

2 Right-click 3D Plot Group 2  and choose Volume .

3 Go to the Volume settings window. Under Data from the Data set list, select Solution 2.

4 Click Replace Expression  in the upper-right corner of the Expression section. From 
the menu, choose Magnetic Fields>Coil parameters>Coil voltage (mf.VCoil).

5 Under Coloring and Style from the Color table list, 
select Thermal.

6 In the Model Builder, right-click 3D Plot Group 2  
and choose Volume . A Volume 2 node is 
added to the Model Builder. 

7 Go to the Volume settings window. Under 
Data from the Data set list, select Solution 3.

8 Click the Plot  button. On the Graphics 
window toolbar, click the Zoom In  button 
twice.
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DERIVED VALUES

The coil inductance and resistance are available as predefined variables, which are 
displayed as follows.

1 In the Model Builder under Results, right-click Derived Values  and choose Global 
Evaluation . 

2 In the Global Evaluation settings window, locate the Expression section.
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3 In the Expression edit field, enter mf.VCoil_1/mf.ICoil_1.

4 Click the Evaluate  button. The results are available in the Results window table 
located in the lower right side of the COMSOL Desktop. Or select View>Results  
from the main menu to open the Results window. 

5 In the Model Builder, right-click Derived Values  and choose Global Evaluation .

6 In the Global Evaluation settings window, in 
the Expression field, enter 2*mf.intWm/
mf.ICoil_1^2.

7 Click the Evaluate  button and compare 
the results in the Results window. 

You can also click the down arrow next to the Evaluate button  on the settings 
window to view each table. You should get about 0.29 m and 0.11 mH, respectively. 

MAGNETIC FIELDS (MF)

As can be seen in the Magnetic Flux Density plot, this is effectively contained within 
the core. Thus, there should be little need to use infinite elements in this model. 
Solve the model without the infinite elements to test this hypothesis.
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1 In the Model Builder under Model 1, click Magnetic Fields .

2 In the Magnetic Fields settings window, select domains 5–8 and 14 only. 

STUDY 1

1 In the Model Builder, right-click Study 1  and choose Compute .

DERIVED VALUES

1 In the Model Builder under Results>Derived Values, click Global Evaluation 1 . 

2 In the Global Evaluation settings window, click the Evaluate  button. The Inductance 
value displays in the Results window table. 

3 In the Model Builder, click Global Evaluation 2 .

4 In the Global Evaluation settings window, click the Evaluate  button. The Resistance 
value displays in the Results window table. The results change very little.

MODEL WIZARD

Next, add a simple circuit to the model.
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1 In the Model Builder, right-click Model 1  and choose Add Physics .

2 In the Add physics tree under AC/DC, double-click Electrical Circuit (cir)  to add it to 
the Selected physics list. You do not need to add any studies. Click Finish .

MAGNETIC FIELDS (MF)

Change the field excitation so that it can connect to the circuit part of the model.

1 In the Model Builder, under Magnetic Fields>Single-Turn 
Coil Domain 1 click Boundary Feed 1. . 

2 In the Boundary Feed settings window under 
Single-Turn Coil Domain, choose Circuit (current) from 
the Coil excitation list.

ELECTRICAL CIRCUIT (CIR)

Add a resistor in series with the inductor and drive. This is done for both by applying 
a voltage source.
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Voltage Source 1
1 In the Model Builder under Model 1, right-click 

Electrical Circuit  and choose Voltage 
Source . 

The default settings correspond to a DC 
source of 1 V between nodes 1and 0 in the 
circuit net. Keep these settings.

Resistor 1
1 In the Model Builder, right-click Electrical 

Circuit  and choose Resistor .

2 Go to the Resistor settings window. Under 
Node Connections enter 1 and 2 in the Node 
names table as in the figure to the right.

3 Under Device Parameters in the R field, enter 
100[mohm].
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External I Vs. U 1
There is a special feature for connecting the 
circuit to the finite elements model.

1 In the Model Builder, right-click Electrical 
Circuit  and choose External I Vs. U .

2 In the External I Vs. U settings window under 
Node Connections, enter Node names as in to 
the figure to the right.

3 Under External Device, from the Electric 
potential V list choose Coil voltage (mf/stcdp1).

The sequence of nodes under Electrical Circuit 
should match this figure. 

STUDY 1

1 In the Model Builder, right-click Study 1  and choose Compute .
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RESULTS

The current is now limited to approximately 10 A by the external resistor which has 
a much larger resistance than that of the winding. 

MODEL WIZARD - ADD A SECOND STUDY

Now, set up the model for computing the frequency-dependent impedance.

1 In the Model Builder, right-click the top node Untitled.mph (root) and choose Add Study.

2 In the Select Study Type window that opens, under Studies>Preset Studies for Selected 
Physics click Frequency Domain .

3 Find the Selected physics subsection. 
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4 In the Selected physics table under Solve for, click to change the check mark to an X and 
remove the  Electrical Circuit (cir) interface.

5 Click Finish .

A Study 2 node with a Frequency Domain study step is 
added to the Model Builder. 

DEFINITIONS

At high frequencies, the skin depth of the copper conductor in the winding becomes 
difficult to resolve. The solution is to exclude the interior of the copper domain from 
the simulation and instead represent the winding by a boundary condition, which 
introduces surface losses via an equivalent surface impedance. For this purpose add 
a boundary selection and an associated surface material.

Conductor Boundaries
1 In the Model Builder under Model 1, right-click 

Definitions  and choose Selections>Explicit .

2 Select Domains 7, 8, and 14 only.

3 Go to the Explicit settings window. Under 
Output Entities from the Output entities list, 
select Adjacent boundaries.

4 Press F2 and choose Rename .

5 In the Rename Explicit window enter Conductor 
Boundaries in the New name field. Click OK.
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MATERIALS

Copper (2)
1 From the main menu, select View>Material 

Browser . In the Materials tree under AC/DC, 
right-click Copper and choose  Add Material 
to Model. 

2 In the Model Builder, click Copper (2). 

3 Go to the Material settings window. Under 
Geometric Entity Selection:

- From the Geometric entity level list, select 
Boundary.

- From the Selection list, select Conductor 
Boundaries.

MAGNETIC FIELDS (MF)

1 In the Model Builder under Model 1, click Magnetic Fields .

2 Go to the Magnetic Fields settings window. Under Domain 
Selection from the Selection list, select Non-conducting 
without IE.

Ampère's Law 2
Apart from the surface loss in the copper conductor, there are also AC losses in the 
core. The loss in the core is introduced as an effective loss tangent. For this purpose 
an extra equation/constitutive relation is required.

1 In the Model Builder, right-click Magnetic Fields  and choose Ampère's Law . A second 
Ampère's Law node is added to the Model Builder.

2 Go to the Ampère's Law settings window. Under Domain Selection from the Selection list, 
select Core.
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3 Under Electric Field from the r list, select User defined and enter 1-5e-4*j in the field. 

Impedance Boundary Condition 1
1 In the Model Builder, right-click Magnetic Fields  and at the boundary level, choose 

Impedance Boundary Condition .

2 Go to the Impedance Boundary Condition settings window. Under Boundary Selection 
from the Selection list, select Conductor Boundaries.

Disable the Single-Turn Coil Domain 1
The Single Turn Coil Domain does not apply to an active domain anymore so it needs 
to be disabled. 

• In the Model Builder, under Magnetic Fields right-click Single-Turn Coil Domain 1  and 
choose Disable . The node is greyed out.

Lumped Port 1
The electric potential is not available in this physics interface, so to excite the model a 
different boundary feature, which is more appropriate for high frequency modeling, must 
be used.
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1 In the Model Builder, right-click Magnetic Fields and at the boundary level choose Lumped 
Port . A Lumped Port node is added to the sequence in the Model Builder. 

2 Go to the Lumped Port settings window. Select 
boundaries 59–62 only. 

The geometrical parameters of the boundary 
set need to be entered manually. 

3 Under Port Properties from the Type of port list, 
select User defined.

- In the hport field, enter 0.024.

- In the wport field, enter 0.046.

4 Specify the ah vector as in the figure to the right.

5 From the Terminal type list, select Current. 

The Model Builder node sequence under Magnetic 

Fields should match this: 

STUDY 2

Set up a frequency sweep from 1-10 MHz in steps of 1 MHz.

1 In the Model Builder, expand the Study 2 node and click Step 1: Frequency Domain .
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2 Under Study Settings, click the Range  button.

3 In the Range window, enter these settings:

- In the Start field, enter 1e6. 

- In the Step field, enter 1e6.

- In the Stop field, enter 1e7.

4 Click Replace.

Near the resonance frequency, the problem becomes ill-conditioned. If there were 
no loss, it would even become singular as the field solution then would approach 
infinity. Thus for a high Q factor, the iterative solver may fail to converge and then a 
direct solver must be used. Here it is sufficient to tweak the iterative solver to use a 
more robust preconditioner.

Solver 2
1 In the Model Builder, right-click Study 2  and choose Show Default Solver .

2 In the Model Builder, expand the Study 2  
>Solver Configurations  nodes as in the 
figure to the right and then click the 
Iterative 1  node. 

3 Go to the Iterative settings window. Under 
General select Right from the 
Preconditioning list.

4 In the Model Builder, right-click Study 2  
and choose Compute .

RESULTS

Magnetic Flux Density 
Again check the default plot for any modeling errors. Note that the magnetic flux 
density inside the copper winding is not computed as this domain was excluded.
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Plot the surface current distribution at the lowest frequency solved for. This 
frequency is below resonance and the device is still of an inductive nature.

Data Sets 
1 In the Model Builder under Results>Data Sets, right-click 

Solution 4  and choose Duplicate .

2 Right-click Solution 5  and choose Add Selection . 

3 Go to the Selection settings window. Under Geometric Entity 
Selection from the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Conductor Boundaries.

3D Plot Group 4
1 In the Model Builder, right-click Results  and choose 

3D Plot Group . A 3D Plot Group 4 node is added to 
the sequence.

2 Go to the 3D Plot Group settings window. Under Data 
from the Data set list, choose Solution 5.
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3 From the Parameter value (freq) list, choose 10e5.

4 Right-click 3D Plot Group 4  and choose Surface . 

5 Go to the Surface settings window. In the 
upper-right corner of the Expression section, click 
Replace Expression . 

6 From the menu, choose Magnetic Fields>Currents 
and charge>Surface current norm (mf.normJs) 
(when you know the variable name, as in this 
exercise, you can also enter mf.normJs in the 
Expression field).

7 Click the Plot  button.

The plot shows the surface current distribution and should match this figure.

Change to the highest frequency solved for and compare the results. Finish the 
modeling session by plotting the real and imaginary parts of the coil impedance.

1D Plot Group 5
1 In the Model Builder, right-click Results  and choose 1D Plot Group .

2 In the 1D Plot Group settings window under Data, select Solution 4 from the Data set list.

3 Under Results right-click 1D Plot Group 5  and choose Global .
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4 Go to the Global settings window. Under y-Axis Data in the Expression column, enter 
real(mf.Zport_1). In the Description column, enter Lumped port impedance.

Note: In general, you can click the Replace Expression  to see what variables are 
available in the predefined lists. In this case, you can enter the information directly into 
the table.

5 Click the Plot  button.

The resistive part of the coil impedance peaks at the resonance frequency.

1D Plot Group 6
1 In the Model Builder, right-click Results  and choose 1D Plot Group .

2 Go to the 1D Plot Group settings window. Under Data from the Data set list, select 
Solution 4.

3 Under Results right-click 1D Plot Group 6  and choose Global .
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4 Go to the Global settings window. Under y-Axis Data in the Expression column, enter 
imag(mf.Zport_1). In the Description column, enter Lumped port impedance.

5 Click the Plot  button.

The reactive part of the coil impedance changes sign when passing through the resonance frequency, 
going from inductive to capacitive.

As a final step, pick one of the plots to use as a model thumbnail.

1 In the Model Builder under Results click 3D Plot Group 2 .

2 From the File menu, choose Save Model Thumbnail. 

To view the thumbnail image, click the Root node and look under the Model Thumbnail 
section. Make adjustments to the image in the Graphics window using the toolbar 
buttons until the image is one that is suitable to your purposes.

This concludes this introduction.
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