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Introduction

Computer simulation has become an essential part of science and engineering. 
Digital analysis of components, in particular, is important when developing new 
products or optimizing designs. Today a broad spectrum of options for simulation 
is available; researchers use everything from basic programming languages to 
various high-level packages implementing advanced methods. Though each of 
these techniques has its own unique attributes, they all share a common concern: 
Can you rely on the results?
When considering what makes software reliable, it’s helpful to remember the goal: 
you want a model that accurately depicts what happens in the real world. A 
computer simulation environment is simply a translation of real-world physical 
laws into their virtual form. How much simplification takes place in the translation 
process helps to determine the accuracy of the resulting model.
It would be ideal, then, to have a simulation environment that included the 
possibility to add any physical effect to your model. That is what COMSOL is all 
about. It’s a flexible platform that allows even novice users to model all relevant 
physical aspects of their designs. Advanced users can go deeper and use their 
knowledge to develop customized solutions, applicable to their unique 
circumstances. With this kind of all-inclusive modeling environment, COMSOL 
gives you the confidence to build the model you want with real-world precision.
Certain characteristics of COMSOL become apparent with use. Compatibility 
stands out among these. COMSOL requires that every type of simulation included 
in the package has the ability to be combined with any other. This strict 
requirement actually mirrors what happens in the real world. For instance in 
nature, electricity is always accompanied by some thermal effect; the two are fully 
compatible. Enforcing compatibility guarantees consistent multiphysics models, 
and the knowledge that, even as the COMSOL family of products expands, you 
never have to worry about creating a disconnected model again.
Another noticeable trait of the COMSOL platform is adaptability. As your 
modeling needs change, so does the software. If you find yourself in need of 
including another physical effect, you can just add it. If one of the inputs to your 
model requires a formula, you can just enter it. Using tools like parameterized 
geometry, interactive meshing, and custom solver sequences, you can quickly 
adapt to the ebbs and flows of your requirements.
COMSOL Multiphysics also has several problem-solving benefits. When starting 
a new project, using COMSOL helps you understand your problem. You are able 
to test out various geometrical and physical characteristics of your model, so you 
can really hone in on the important design challenges. The flexible nature of the 
COMSOL environment facilitates further analysis by making “what-if” cases easy 
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to set up and run. You can take your simulation to the production level by 
optimizing any aspect of your model. Parameter sweeps and target functions can 
be executed right in the user interface. From start to finish, COMSOL is a 
complete problem-solving tool.
As you become a more experienced user of COMSOL, your confidence in 
computer simulation will grow. You will become a more efficient modeler, and the 
results will show it. The remainder of this introduction is dedicated to give you a 
strong start toward this goal. After a general introduction to the user interface, 
several tutorials will take you step by step through sample models that highlight 
important features. The informative charts give you an idea of COMSOL’s 
capability by associated files, functions, and built-in options. By the end you will 
be well on your way to reaping all the benefits that COMSOL has to offer.
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The COMSOL Desktop

The user interface streamlines the modeling workflow with the Model Builder. 
Containing a Model Tree, the Model Builder outlines the structure of your model.
Look at this example of the Model Builder. Every step of the modeling process, 
from defining global variables to the final report of results, is displayed in the 
Model Tree.

When you right-click any node in the tree, a context menu shows the available 
features. In addition, many nodes can be easily moved up and down in the model 
tree by dragging and dropping the nodes. You can also right-click to copy, delete, 
disable, or enable nodes.
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If you choose an action that requires specification, the matching settings window 
displays next to the Model Builder:

Click any associated node to return to a specific settings window.
As you create the model, each step is shown in the Model Builder. If, for example, 
your model required a certain sequence of steps to get the right geometry, these 
are all listed in the order you set. This series of steps can be edited and rerun 
without having to repeat the entire simulation. Solver sequences with multiple 
study steps also benefit greatly from this feature.
As you work with the COMSOL Desktop and the Model Builder, you will grow 
to appreciate the organized and streamlined approach. But any description of a 
user interface is inadequate until you try it for yourself. So in the next few sections, 
you are invited to work through some examples to familiarize yourself with the 
software.

A selected node and its settings window.
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Thorough Example: The Busbar

Electrical Heating in a Busbar
In order to get acquainted with COMSOL Multiphysics, it is best to work through 
a basic example step by step. These instructions describe the essential components 
of the model building procedure, highlighting several features and demonstrating 
the common simulation tasks. At the end, you will have built a truly multiphysics 
model.
The model that you are about to create analyzes a busbar designed to conduct 
direct current to an electric device (see below). The current conducted in the 
busbar, from bolt 1 to bolts 2a and 2b, produces heat due to the resistive losses, 
a phenomenon referred to as Joule heating. The busbar is made of copper while 
the bolts are made of a titanium alloy. The choice of materials is important because 
titanium has a lower electrical conductivity than copper and will be subjected to a 
higher current density. 

The goal of your simulation is to precisely calculate how much the busbar heats 
up. Once you have captured the basic multiphysics phenomena, you will have the 
chance to investigate thermal expansion yielding structural stresses and strains in 
the busbar and the effects of cooling by an air stream.
The Joule heating effect is described by conservation laws for electric current and 
energy. Once solved for, the two conservation laws give the temperature and 
electric field, respectively. All surfaces, except the bolt contact surfaces, are cooled 
by natural convection in the air surrounding the busbar. You can assume that the 
bolt cross-section boundaries do not contribute to cooling or heating of the 
device. The electric potential at the upper-right vertical bolt surface is 20 mV, and 
that the potential at the two horizontal surfaces of the lower bolts is 0 V.

Titanium Bolt 2a

Titanium Bolt 1Titanium Bolt 2b
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Busbar Model Overview
More in depth and advanced topics included with this tutorial are used to show 
you some of the many options available in COMSOL. The following topics are 
covered:
• “Parameters, Functions, Variables, and Model Couplings” on page 31, 

where you learn how to define functions and model couplings.
• “Material Properties and Libraries” on page 36 shows you how to customize 

a material and add it to your own material library.
• “Meshing Sequences” on page 38 gives you the opportunity to add and 

define two different mesh nodes and compare two meshes generated and 
displayed in the Graphics window.

• “Adding Physics to a Model” on page 41 explores the multiphysics 
capabilities by adding a Solid Mechanics interface and a Laminar Flow 
interface to the busbar model.

• “Parametric Sweeps” on page 61 gives you some practice of how to make 
minor changes to the busbar design and quickly view the differences in the 
Graphics window. Use this analysis to make design changes to a model.

• In the section “Parallel Computing” on page 69, you experiment with 
adding a Cluster Computing node.

• The last section, “Geometry Sequences” on page 71, contains the 
step-by-step instructions to build the busbar geometry in COMSOL instead 
of importing or opening it from a file.

Model Wizard

1 Open the Model Wizard. 
To open the Model Wizard, double-click the COMSOL icon on the desktop. 
Or when COMSOL is already open:
- Click the New button  on the main toolbar
- Select File>New from the main menu
- Right-click the root node and select Add Model
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2 When the Model Wizard opens, select a 
space dimension; the default is 3D. 
Click the Next button .

3 In the Add Physics window, click the Heat 
Transfer>Electromagnetic Heating folder, 
then right-click Joule Heating  and 
choose Add Selected. Click the Next 
button . 
You can also double-click or click the Add 
Selected button  to add physics.
Another way to open the Add Physics 
window is to right-click the Model node 
and select Add Physics .
Note that you may have a lot more items 
in your physics list depending on the 
add-on modules installed. The figure on 
the right is shown for the case where there 
are no add-on modules installed.

4 In the Select Study Type window, click to 
select the Stationary  study type. 
Click the Finish button . 
Preset Studies are studies that have solver 
and equation settings adapted to the 
selected physics, in this example, Joule 
heating. Any selection from the Custom 
Studies branch  needs manual 
fine-tuning.
Note also here that you may have a lot 
more study types in your study list 
depending on the installed add-on modules.
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Global Definit ions

If you want to draw the geometry yourself, 
the Global Definitions branch is where you 
define the parameters. First complete the 
steps 1 to 3 below to define the parameter list 
for the model and then skip to the section 
“Geometry Sequences” on page 71. You may 
then return to this section and use this 
busbar.mph file. If you would prefer to load 
the geometry with its parameters from a file, 
you can just browse through this section and 
then skip to “Geometry” on page 9.
The Global Definitions node  in the Model 
Builder stores Parameters, Variables, and 
Functions with a global scope. You can use 
these operations in several models. In this 
case, there is only one Model 1 node where 
the parameters are used.
Since you will run a geometric parameter study later in this example, define the 
geometry using parameters from the start. In this step, enter parameters for the 
length for the lower part of the busbar, L, the radius of the titanium bolts, rad_1, 
the thickness of the busbar, tbb, and the width of the device, wbb.
You will also add the parameters that control the mesh, mh, a heat transfer 
coefficient for cooling by natural convection, htc, and a value for the voltage 
across the busbar, Vtot.
1 Right-click Global Definitions  and choose Parameters . In the Parameters 

table, click the first row under Name and enter L. 
2 Click the first row under Expression and enter the value of L, 9[cm]. You can 

enter any unit inside the square brackets. 

L

2xrad_1

wbb

tbb
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3 Continue adding the other parameters: L, rad_1, tbb, wbb, mh, htc, and  
Vtot according to the Parameters list. It is a good idea to enter descriptions 
for variables in case you want to share the model with others and for  
future reference.

Geometry

In the previous section, “Global Definitions”, you learned how to enter 
parameters in preparation for drawing the busbar geometry or importing a 
geometry from another program. The next step is to either open this predefined 
geometry file from the Model Library or build the busbar geometry yourself. If 
you want to learn how to use the COMSOL geometry tools and draw the busbar, 
then click the Save button  and name the model busbar.mph. Then go to 
“Geometry Sequences” on page 71. 
Alternatively, and if you want to save time, the model geometry can be opened 
from the Model Library, as described here. 
Once a geometry is created, imported, or opened from the Model Library, you can 
then experiment with different dimensions and update the values of L, tbb, or 
wbb, and rerun the geometry sequence. The physics, study, parameters, and 
geometry are included with the model file you are about to open.
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1 Select Model Library  from the main 
View menu.

2 In the Model Library tree under 
COMSOL Multiphysics> 
Multiphysics, select busbar_geom. 

To open the model file you can:
- Double-click it
- Right-click and select an option 

from the menu
- Click one of the buttons under the 

tree

Now experiment with different 
geometry expressions for the width 
parameter, wbb.

If you built the geometry yourself, start from this point to experiment with 
the geometry expressions using the busbar.mph file you saved after 
completing the steps “Global Definitions” on page 8 and “Geometry 
Sequences” on page 71.
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3 Under Global Definitions  click the 
Parameters node . 
In the Parameters settings window, click 
in the wbb parameter’s Expression 
column and enter 10[cm] to change the 
value of the width wbb.

4 In the Model Builder, click the Form 
Union node  and then the Build All 
button  to rerun the geometry 
sequence.

5 In the Graphics toolbar click the Zoom Extents button  to see the wider 
busbar in the Graphics window. 

wbb=5cm wbb=10cm
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6 Experiment with the geometry in the Graphics window. Also see “Working 
with 3D Geometry in the Graphics Window” on page 107.
- To rotate the busbar, left-click and drag it
- To move it, right-click and drag
- To zoom in and out, center-click (and hold) and drag
- To get back to the original position, click the Go to Default 3D View button 

 on the toolbar

7 Return to the Parameters table and 
change the value of wbb back to 5[cm].

8 In the Model Builder, click the Form 
Union node  and then the Build All 
button  to rerun the geometry 
sequence.

9 On the Graphics toolbar, click the 
Zoom Extents button .

10If you built the geometry yourself you are already using the busbar.mph file. 
But if you opened the Model Library file, from the main menu, select 
File>Save As and rename the model busbar.mph. 

Experienced users of other CAD programs are already familiar with this 
approach since all major CAD platforms include parameterized 
geometries. To support this class of users and to avoid redundancy, 
COMSOL offers the LiveLink™ family of products. These products 
connect COMSOL Multiphysics directly with a separate CAD program, so 
that all parameters specified in CAD can be interactively linked with your 
simulation geometry. The current product line includes LiveLink™ 
interfaces for SolidWorks®, Inventor®, Pro/ENGINEER®, Creo™ 
Parametric, Solid Edge®, AutoCAD®, and SpaceClaim®.
It is also worth noting that the LiveLink™ interfaces for MATLAB® and 
Microsoft Excel® are available for those who want to incorporate a 
COMSOL Multiphysics model into an extended programming 
environment or link to spreadsheets.
After creating or opening the geometry file, it is time to define the 
materials.
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Materials

The Materials node  stores the material properties for all physics and domains in 
a Model node. The busbar is made of copper and the bolts are made of titanium. 
Both these materials are available from the Built-In material database.
1 In the Model Builder, right-click Materials  and select Open Material Browser 

 (or select View>Material Browser). 

The Materials node has a red x in the lower right-hand corner to indicate 
that there is an error, in this case, missing information. For more 
information about this, see “COMSOL Multiphysics—Additional 
Concepts” in the section “Other Node Types” on page 101.

2 In the Material Browser, expand the 
Built-In materials folder and locate 
Copper. Right-click Copper and select  
Add Material to Model. 
A Copper node is added to the Model 
Builder.

3 Click the Material Browser tab.

4 In the Material Browser, scroll to 
Titanium beta-21S in the Built-In material 
folder tree. Right-click and select  Add 
material to model. 
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5 In the Model Builder, collapse the Geometry 1 node  to get an overview of 
the model.

6 Under the Materials node , click Copper.

7 In the Material settings window, examine the Material Contents section.

The Material Contents section has useful feedback about the model’s material 
property usage. Properties that are both required by the physics and available 
from the material are marked with a green check mark . Properties required 
by the physics but missing in the material result in an error and are marked with 
a warning sign . A property that is available but not used in the model is 
unmarked.

The Coefficient of thermal expansion property is not used, but it is needed 
later when heat induced stresses and strains are added to the model.
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Because the copper material is added first, by default all parts have copper 
material assigned. In the next step you will assign titanium properties to the 
bolts, which overrides the copper material assignment for those parts (in the 
section “Adding Solid Mechanics” on page 42).

8 In the Model Builder, click Titanium beta-21S.

9 Select All Domains from the Selection list and then click domain 1 in the list. 
Now remove Domain 1. 
To remove a domain (or any geometric entity such as boundaries, edges, or 
points), you can:
- Click Domain 1 in the selection list found in the Material settings window, 

then click the Remove from Selection button 
- In the Graphics window, click domain 1 and right-click to remove it from the 

selection list 
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10In the Material settings window, be 
sure to inspect the Material Contents 
section for the titanium material. All 
the properties used by the physics 
interfaces should have a green check 
mark .

Close the Material Browser.

Cross-check: Domains 2, 3, 4, 5, 6, and 7.
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Physics

The domain settings for the Joule Heating interface are complete now that you 
have set the material properties for the different domains. Next you will set the 
boundary conditions for the heat transfer problem and the conduction of electric 
current.
1 In the Model Builder, expand the 

Joule Heating node  to examine the 
default physics nodes.
The ‘D’ in the upper left corner of a 
node’s icon ( ) means it is a default 
node.
The equations that COMSOL solves 
are displayed in the Equation section 
of the settings window. The equations 
change based on the Equation form 
selected. 
The default equation form is inherited 
from the study added in the Model 
Wizard. For the Joule Heating node, 
COMSOL displays the equations 
solved for the temperature and 
electric potential.

To always display the section in its expanded view, click the Expand 
Sections button ( ) on the Model Builder toolbar and select Equations. 
Selecting this option expands all the Equation sections on physics settings 
windows.
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The domain level Joule Heating 
Model 1 node has the settings for heat 
conduction and current conduction. 
The contribution of the Joule 
Heating Model 1 node to the entire 
equation system is underlined in the 
Equation section. 
The heating effect for Joule heating is 
set in the Electromagnetic Heat 
Source 1 node. The Thermal 
Insulation 1 node contains the default 
boundary condition for the heat 
transfer problem and Electric 
Insulation 1 corresponds to the 
conservation of electric current.  
The Initial Values 1 node contains 
initial guesses for the nonlinear  
solver for stationary problems and 
initial conditions for time-dependent 
problems.

2 Right-click the Joule Heating node . In the second section of the context 
menu—the boundary  section—select Heat Transfer>Heat Flux. 

Boundary section

Domain section
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3 In the Heat Flux settings window, select 
All boundaries from the Selection list.
Assume that the circular bolt boundaries 
are neither heated nor cooled by the 
surroundings.
In the next step you will remove these 
boundaries from the heat flux selection 
list, which leaves them with the default 
insulating boundary condition for the 
Heat Transfer interfaces.

4 Rotate the busbar to view the back. Click one of the circular titanium bolt 
surfaces to highlight it in green. Right-click anywhere in the Graphics window 
to remove this boundary from the Selection list. Repeat this step to remove the 
other two bolts from the selection list. Boundaries 8, 15, and 43 are removed.

5 In the Heat Flux settings window 
under Heat Flux, click the Inward heat 
flux button. Enter htc in the Heat 
transfer coefficient field, h.
This parameter was either entered in 
the Parameter table in “Global 
Definitions” on page 8 or imported 
with the geometry.
Continue by setting the boundary 
conditions for the electric current.

Cross-check: Boundaries 8, 15, and 43 are removed 
from the Selection list.
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6 In the Model Builder, right-click the Joule Heating node . In the second 
section of the context menu—the boundary section—select Electric 
Currents>Electric Potential. An Electric Potential  node is added to the 
Model Builder. 

7 Click the circular face of the upper 
titanium bolt to highlight it and 
right-click anywhere to add it 
(boundary 43) to the Selection list.

8 In the Electric Potential settings 
window, enter Vtot in the Electric 
potential field.
The last step is to set the two 
remaining bolt surfaces to ground.
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9 In the Model Builder, right-click the Joule Heating node . In the boundary 
section of the context menu, select Electric Currents>Ground. A Ground node 

 is added to the Model Builder. The node sequence under Joule Heating 
should match this figure.

10In the Graphics window, click one 
of the remaining bolts to highlight 
it. Right-click anywhere to add it 
to the Selection list.
Repeat this step to add the last 
bolt. Boundaries 8 and 15 are 
added to the selection list.

11On the Graphics toolbar, click the Go to Default 3D View button .

Cross-check: Boundaries 8 and 15.
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Mesh

The simplest way to mesh is to create an unstructured tetrahedral mesh, which is 
perfect for the busbar. Alternatively, you can create several meshing sequences as 
shown in “Meshing Sequences” on page 38. 

A physics-controlled mesh is created by default. In most cases, it is possible 
to skip to the Study branch and just solve the model. For this exercise, the 
settings are investigated in order to parameterize the mesh settings.

1 In the Model Builder, click the Mesh 1 
node . In the Mesh settings window, 
select User-controlled mesh from the 
Sequence type list. 

2 Under Mesh 1, click the Size node . 
The asterisk (*) that displays in the 
upper-right corner of the icon indicates 
that the node is being edited.

3 In the Size settings window under 
Element Size, click the Custom 
button. 
Under Element Size Parameters, enter:
- mh in the Maximum element size 

field. Notice that mh is 6 mm—the 
value entered earlier as a global 
parameter. By using the parameter 
mh, the variations in element size are 
limited. 

- mh-mh/3 in the Minimum element 
size field. The Minimum element 
size is slightly smaller than the 
maximum size. 
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- 0.2 in the Resolution of curvature field. The resolution of curvature 
determines the number of elements on curved edges: a lower value gives a 
finer mesh along curved boundaries. The Maximum element growth rate 
determines how fast the elements should grow from small to large over a 
domain. The larger this value is, the larger the growth rate. A value of 1 does 
not give any growth. 

The Resolution of narrow regions works in a similar way to the resolution of 
curvature.

4 Click the Build All button  in the Size settings window to create the mesh as 
in this figure: 
Thorough Example: The Busbar | 23



Study

1 To run a simulation, in the Model 
Builder, right-click Study 1  and 
choose Compute . Or press F8.

The Study node  automatically 
defines a solution sequence for the 
simulation based on the selected 
physics and the study type. The 
simulation only takes a few seconds 
to solve.

Results

The default plot displays the temperature in the busbar. The temperature 
difference in the device is less than 10 K due to the high thermal conductivity of 
copper and titanium. The temperature variations are largest on the top bolt, which 
conducts double the amount of current compared to the two lower bolts. The 
temperature is substantially higher than the ambient temperature of 293 K.
1 Click and drag the image in the 

Graphics window to rotate and 
view the back of the busbar.

2 On the Graphics toolbar, click 
the Go to Default 3D View 
button .
You can now manually set the 
color table range to visualize 
the temperature difference in 
the copper part.

3 In the Model Builder, expand the Results>Temperature node  and click the 
Surface 1 node . 
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4 In the Surface settings window, click Range to expand the section. Select the 
Manual color range check box and enter 323 in the Maximum field (replace the 
default). 
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5 Click the Plot button  on the Surface settings window. On the Graphics 
toolbar, click the Zoom Extents button  to view the updated plot. 

6 Click and drag in the Graphics window to rotate the busbar and view the back. 

The temperature distribution is symmetric with a vertical mirror plane running 
between the two lower titanium bolts and running across the middle of the upper 
bolt. In this case, the model does not require much computing power and you can 
model the whole geometry. For more complex models, you can consider using 
symmetries in order to reduce the size of the model. 
Now let us generate the Surface plot that shows the current density in the device.
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1 In the Model Builder, right-click 
Results  and add a 3D Plot Group . 
Right-click 3D Plot Group 2  and 
add a Surface node .

2 In the Surface settings window under Expression, click the Replace Expression 
button . Select Joule Heating (Electric Currents)>Currents and 
charge>Current density norm (jh.normJ). 
jh.normJ is the variable for the magnitude, or absolute value, of the current 
density vector. You can also enter jh.normJ in the Expression field when you 
know the variable name.

3 Click the Plot button . 
The plot that displays in the Graphics window is almost uniform in color due to 
the high current density at the contact edges with the bolts. The next step is to 
manually change the color table range to visualize the current density 
distribution. 

4 On the Surface settings window under Range, select the Manual color range 
check box. Enter 1e6 in the Maximum field and replace the default.
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5 Click the Plot button . The plot automatically updates in the Graphics 
window
The resulting plot shows how the current takes the shortest path in the 
90-degree bend in the busbar. Notice that the edges of the busbar outside of 
the bolts are hardly utilized for current conduction.
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6 Click and drag the busbar in the Graphics window to view the back. Continue 
rotating the image to see the high current density around the contact surfaces 
of each of the bolts. 

Make sure to save the model. This version of the model, busbar.mph, is 
reused and renamed during the next set of tutorials.

When you are done, click the Go to Default 3D View button  on the Graphics 
toolbar and create a model thumbnail image.

CREATING MODEL IMAGES FROM PLOTS

With any solution, you can create an image to display in COMSOL when 
browsing for model files. After generating a plot select File>Save Model 
Thumbnail from the main menu.
There are two other ways to create images from a plot. One is to click the Image 
Snapshot button  in the Graphics toolbar to directly create an image. You can 
also add an Image node  to an Export node, for creating image files, by 
right-clicking the plot group of interest and then selecting Add Image to Export. 
This completes the first part of the introduction to a multiphysics simulation. The 
next sections are designed to increase your understanding of the steps you 
implemented up to this point as well as to extend your simulation to include other 
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relevant effects, like thermal expansion and fluid flow. These additional tutorial 
sections start on the following pages:
• “Parameters, Functions, Variables, and Model Couplings” on page 31
• “Material Properties and Libraries” on page 36 
• “Meshing Sequences” on page 38 
• “Adding Physics to a Model” on page 41
• “Parametric Sweeps” on page 61
• “Parallel Computing” on page 69
• “Geometry Sequences” on page 71
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Parameters, Functions, Variables, and Model Couplings

This section explores working with Parameters, Functions, Variables, and Model 
Couplings. 
Global Definitions and Definitions contain functionality that help you to prepare 
model inputs and model couplings and to organize simulations. You have already 
used the functionality for adding Parameters to organize model inputs in “Global 
Definitions” on page 8.
Functions, available as both Global Definitions and Definitions, contain a set of 
predefined functions that can be useful when setting up multiphysics simulations. 
For example, the Step function can create a smooth step function for defining 
different types of switches. 
To illustrate using functions, assume that you want to add a time dependent study 
to the busbar model by applying an electric potential across the busbar that goes 
from 0 V to 20 mV in 0.5 seconds. For this purpose, you could use a step function 
to be multiplied with the parameter Vtot. Add a function that goes smoothly from 
0 to 1 in 0.5 seconds to find out how functions can be defined and verified.

Defining Functions

For this section, you can continue working with the same model file created in the 
previous section. Locate and open the file busbar.mph if it is not already open on 
the COMSOL Desktop.
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1 Right-click the Global Definitions node  and select Functions>Step .

2 In the Step settings window, enter 0.25 in the Location field to set the location 
of the middle of the step, where it has the value of 0.5. 

3 Click Smoothing to expand the section and enter 0.5 in Size of the Transition 
zone to set the width of the smoothing interval. 

4 Click the Plot button  in the Step settings window. 
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If your plot matches the one below, this confirms that you have defined the 
function correctly. 

You can also add comments and rename the function to make it more descriptive.
5 Right-click the Step 1 node 

 in the Model Builder and 
select Properties .

6 In the Properties window, 
enter any information you 
want.
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The Global Definitions  and Definitions  nodes can contain Variables , 
which are expressions of the dependent variables—the variables that are solved for 
in a simulation. You can define global variables that can be used in several models.
For the purpose of this exercise, assume that you want to introduce a second 
model to represent an electric device connected to the busbar through the 
titanium bolts.
A first step would be to rename Model 1 to specify that it represents the busbar.
1 Right-click the Model 1 node  and select Rename  (or press F2).
2 In the Rename Model window, enter Busbar. Click OK and save the model.

Defining Model Couplings

This section is for information only. You do not 
need to reproduce the below instructions to 
continue modeling in this chapter. 
Click the Definitions node  under Busbar 
(mod1) to introduce a Model Coupling that 
integrates any Busbar (mod1) variable at the 
bolt boundaries facing the electric device. You 
can use this coupling to define a Variable—in 
Global Definitions—that calculates the total 
current. This variable is then globally accessible 
and could, for example, form a boundary 
condition for the current that is fed to the 
electric device in the Electric  
Device (mod2) node.
The Model Couplings in Definitions have a wide range of use. The Average , 
Maximum , and Minimum  model couplings have applications in generating 
results as well as in boundary conditions, sources, sinks, properties, or any other 
contribution to the model equations. The Probes  are for monitoring the 
solution progress. For instance, you can follow the solution in a critical point 
during a time-dependent simulation or at parameter value in a parametric study. 
34 | Parameters, Functions, Variables, and Model Couplings



You can also use Model Couplings to map variables from one face in a model to 
another (extrusion couplings) or to integrate a variable along curves and map from 
one entity to another (projection couplings). 
You can find an example of using the average operator in “Parametric Sweeps” on 
page 61. Also see “Built-in Functions” on page 117, for a list of available 
COMSOL functions.

To learn more about working with definitions, in the Model Builder click the 
Definitions  or Global Definitions  node and press F1 to open the Help 
window . This window displays help about the selected item in the 
COMSOL Desktop and provides links to the documentation. It could take 
up to a minute for the window to load the first time it is activated but the 
next time it will load quickly.
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Material Properties and Libraries

Up to now, you have used the functionality in Materials to access the properties 
of copper and titanium in the busbar model. In Materials, you are also able to 
define your own materials and save them in your own material library. You can also 
add material properties to existing materials. In cases where you define properties 
that are functions of other variables, typically temperature, the plot functionality 
helps you to verify the property functions in the range of interest. You can also 
load Excel® spreadsheets and define interpolation functions for material properties 
using LiveLink™ for Excel®.
The Material Library add-on contains over 2500 materials with tens of thousands 
of temperature-dependent property functions.
In the near future, you will also be able to import material properties from CAD 
using the CAD LiveLink add-ons.
First investigate how to add a property to an existing material. Assume that you 
want to add bulk modulus and shear modulus to the copper properties.

Customizing Materials

Let us keep working on the busbar.
1 In the Model Builder, under Materials, click 

Copper .

2 In the Material settings window, the 
Materials Properties section 
contains a list of all the definable 
properties.
Expand the Solid Mechanics>Linear 
Elastic Material section. Right-click 
Bulk Modulus and Shear Modulus 
and select  Add to Material.
This lets you define the bulk 
modulus and shear modulus for the 
copper in your model.
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3 Locate the Material Contents section. Bulk modulus and Shear modulus rows 
are now available in the table. The warning sign  indicates the values are not 
yet defined. To define the values, click the Value column. In the Bulk modulus 
row, enter 140e9 and in the Shear modulus row, enter 46e9.

By adding these material properties, you have changed the Copper material. 
However, you cannot save this in the read-only Solid Mechanics material library 
but you can save it to your own material library.
4 In the Model Builder, right-click Copper and select Add Material to “User 

Defined Library” . 
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Meshing Sequences

A model can contain different meshing sequences to generate meshes with 
different settings. These sequences can then be accessed by the study steps. In the 
study, you can select which mesh you would like to use in a particular simulation.
In the busbar model, a second mesh node is added to create a mesh that is refined 
in the areas around the bolts and the bend. You do this by increasing the mesh 
resolution on curved surfaces. 

Adding a Mesh

Let us keep working on the busbar.
1 In order to keep this model in a separate 

file for later use, from the main menu, 
select File>Save as and rename the model 
busbar_I.mph.

2 To add a second mesh node, right-click the 
Busbar (mod1) node  and select Mesh .
By adding another Mesh node, it creates a 
Meshes parent node that contains both 
Mesh 1 and Mesh 2.
38 | Meshing Sequences



3 Click the Mesh 2 node. In the Mesh 
settings window under Mesh Settings, 
select User-controlled mesh as the 
Sequence type.
A Size and Free Tetrahedral node are 
added under Mesh 2. 

4 In the Model Builder, under Mesh 2, 
click Size .

The asterisk in the upper-right 
corner of a node icon indicates that 
the node is being edited. 

5 In the Size settings window under 
Element Size, click the Custom 
button. 

6 Under Element Size Parameters, 
enter:
- mh/2 in the Maximum element 

size field, where mh is 6 mm—the 
mesh control parameter entered 
earlier

- mh/2-mh/6 in the Minimum 
element size field

- 0.2 in the Resolution of curvature 
field.

7 Click the Build All button .
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Compare Mesh 1 and Mesh 2 by clicking the Mesh nodes. The mesh is updated 
in the Graphics window. An alternative for using many different meshes is to run 
a parametric sweep of the parameter for the maximum mesh size, mh, that was 
defined in the section “Global Definitions” on page 8.

Mesh 1 Mesh 2
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Adding Physics to a Model

COMSOL's distinguishing characteristics of adaptability and compatibility are 
prominently displayed when you add physics to an existing model. In this section, 
you will understand the ease with which this seemingly difficult task is performed. 
By following these directions, you can add structural mechanics and fluid flow to 
the busbar model.

Structural  Mechanics

After completing the busbar Joule heating simulation, we know that there is a 
temperature rise in the busbar. What kind of mechanical stress is induced by 
thermal expansion? To answer this question, let us expand the model to include 
the physics associated with structural mechanics. 

To complete these steps, either the Structural Mechanics Module or the 
MEMS Module (which enhance the standard Solid Mechanics interface) is 
required.
If you want to add cooling by fluid flow, or don’t have the Structural 
Mechanics Module or MEMS Module, read this section and then go to, 
“Fluid Flow” on page 47. 
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Adding Solid Mechanics

1 Open the model busbar.mph that was created earlier. From the main menu, 
select File>Save as and rename the model busbar_II.mph.

2 In the Model Builder, right-click the 
Busbar node  and select Add Physics .

3 In the Model Wizard under Structural 
Mechanics, select Solid Mechanics . 
To add this interface, you can 
double-click it, right-click and select Add 
Selected, or click the Add Selected 
button .

4 Click the Finish button  and save the 
file. You do not need to add any studies. 

When adding additional physics, you need to make sure that materials 
included in the Materials node have all the required properties for the 
selected physics. In this example, you already know that all properties are 
available for copper and titanium.

You can start by adding the effect of thermal expansion to the structural 
analysis. 

5 In the Model Builder under Solid 
Mechanics, right-click the Linear Elastic 
Material 1 node  and from the domain 
level, select Thermal Expansion . 
A Thermal Expansion node is added to the 
Model Builder. 
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6 In the Thermal Expansion settings 
window under Model Inputs, select 
Temperature (jh/jhm1) from the 
Temperature list.
This is the temperature field from the 
Joule Heating interface (jh/jhm1) 
and couples the Joule heating effect to 
the thermal expansion of the busbar. 

With the Structural Mechanics Module, the Thermal Stress  
predefined multiphysics interface is also available to define thermal 
stresses and strains. 

Next, fix the busbar at the position of the titanium bolts.

7 In the Model Builder, right-click Solid Mechanics  and from the boundary 
level, select Fixed Constraint . A node with the same name is added to the 
Model Builder.

8 Click the Fixed Constraint node. In the Graphics 
window, rotate the busbar to view the back. Click 
one of the bolts to highlight it and right-click to 
add the bolt to the Selection list. 

9 Repeat this procedure for the remaining bolts to 
add boundaries 8, 15, and 43.

Next we update the Study to take the added effects into account.
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Running a Study Sequence  
Joule Heating and Thermal Expansion

The Joule heating effect is independent of the stresses and strains in the busbar, 
assuming small deformations and ignoring the effects of electric contact pressure. 
This means that you can run the simulation using the temperature as input to the 
structural analysis. In other words, the extended multiphysics problem is weakly 
coupled. As such, you can solve it in two separate study steps to save computation 
time—one for the strongly coupled Joule heating problem and a second one for 
the structural analysis.
1 In the Model Builder, right-click Study 1  and 

select Study Steps>Stationary  to add a second 
stationary study step.

When adding study steps you need to manually connect the correct 
physics with the correct study step. Start by removing the structural 
analysis from the first step.

2 Under Study 1, click the Step 1: Stationary node .

3 In the Stationary settings window, locate the Physics and Variables Selection.
4 In the Solid Mechanics (solid) row under Solve for, click to change the check 

mark  to an  to remove Solid Mechanics from Study 1.

Now repeat these steps to remove Joule heating from the second study step.
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5 Under Study 1, click Step 2: Stationary 2 .

6 Under Physics and Variables 
Selection, in the Joule Heating 
(jh) row under Solve for, click to 
change the check mark  to an  
to remove Joule Heating from 
Step 2. 

7 Right-click the Study 1 node  
and select Compute  (or press 
F8) to solve the problem.

After a few moments of computation a second plot group is added under Results 
in the Model Builder. Save the file busbarII.mph, which now includes the Solid 
Mechanics interface and the additional study step. 

Resulting Deformation

Now add a displacement to the plot.
1 Under Results>3D Plot Group 2, click the Surface 1 node . 
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2 In the Surface settings window in the 
Expression section, click the Replace 
Expression button . 
From the context menu, select Solid 
Mechanics>Displacement>Total 
Displacement. You can also enter 
solid.disp in the Expression field. 

3 Click Range to expand the section. 
Click to clear the Manual color range 
check box.

The local displacement, due to thermal expansion, is displayed by COMSOL as 
a surface plot. Next add exaggerated deformation information.

4 In the Model Builder, under Results>3D Plot Group 2, right-click the Surface 
1 node  and add a Deformation . The plot automatically updates in the 
Graphics window.

5 Save the busbarII.mph file, which now includes a Surface plot with a 
Deformation. 

You can also plot the von Mises and principal stresses to assess the structural 
integrity of the busbar and the bolts.
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Fluid Flow

After analyzing the heat generated in the busbar and possibly the induced thermal 
stresses, you might want to investigate ways of cooling it by letting air flow over 
its surfaces. These steps do not require any additional modules.

When you have the CFD Module or the Heat Transfer Module, the 
Conjugate Heat Transfer  multiphysics interface is available. This 
automatically defines coupled heat transfer in solids and fluids including 
laminar or turbulent flow. 

Adding fluid flow to the Joule heating model forms a new multiphysics coupling. 
To simulate the flow domain, you need to create an air box around the busbar. 
You can do this manually by altering the geometry from your first model or by 
opening a Model Library file. 
Having loaded or created the geometry, now simulate the air flow according to 
this figure:

Air inlet

Air outlet
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Defining Inlet Velocity

Start by adding a new parameter for the inlet flow velocity.
1 Select View>Model Library  and navigate to COMSOL Multiphysics> 

Multiphysics>busbar_box. Double-click to open the model file, which 
contains the geometry in addition to the steps completed up to the end of 
the section “Customizing Materials” on page 36. 

2 Under Global Definitions, click the Parameters node . 

3 In the Parameters settings window, click the empty row just below the Vtot 
row. In the Name column, enter Vin. Enter 1e-1[m/s] in the Expression 
column and a description of your choice in the Description column.

4 Select File>Save As and save the model with a new name, busbar_box_I.mph. 
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Adding Air

The next step is to add the material properties of air.
1 Select View>Material Browser. 
2 In the Material Browser, expand the 

Built-In tree. Right-click Air and select  
Add Material to Model. Click the Material 
Browser tab and close it.

3 In the Model Builder under Materials, click 
the Air node. 

4 In the Graphics window, click the air box (Domain 1) to highlight it (in red) 
and right-click to add it to the Selection list (which changes the color to blue). 
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Adding Fluid Flow

Now add the physics of fluid flow.
1 In the Model Builder, right-click Model 1  and 

select Add Physics .
2 In the Add Physics tree, under Fluid 

Flow>Single-Phase Flow double-click Laminar 
Flow  to add it to the Selected physics section. 
You do not need to add any more studies. Click 
the Finish button .

3 On the Graphics toolbar, click the Select 
Boundaries button  and then the Wireframe 
rendering button  to look inside the box. 

Now that you have added fluid flow to the model, you need to couple the heat 
transfer part of the Joule Heating interface to the fluid flow.
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4 In the Model Builder, right-click Joule Heating . In the first section of the 
context menu, the domain  level, select Heat Transfer>Heat Transfer in 
Fluids.

5 In the Graphics window select the 
air box (Domain 1) and right-click 
to add it to the Selection list. 
Now couple the fluid flow and the 
heat transfer phenomena.

6 In the Heat Transfer in Fluids 
settings window under Model 
Inputs, select Velocity field (spf/
fp1) from the Velocity field list. 
This identifies the flow field from 
the Laminar Flow interface  and 
couples it to heat transfer.
Now define the boundary 
conditions by specifying the inlet 
and outlet for the heat transfer in 
the fluid domain.
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7 In the Model Builder, right-click Joule Heating . In the second section of the 
context menu, the boundary  section, select Heat Transfer>Temperature. 
A Temperature node is added to the Model Builder

8 In the Graphics window, click the 
inlet boundary, Boundary 2, and 
right-click to add it to the 
Selection list. 
This sets the inlet temperature to 
293.15 K, the default setting. 
Click the Transparency button  
in the Graphics toolbar to turn off 
transparency, since we do not 
need this anymore. Click the 
Wireframe Rendering button  
in the Graphics toolbar. The 
graphics should look like the 
image on the right. Continue by 
defining the outlet.
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9 In the Model Builder, right-click Joule Heating . At the boundary level, select 
Heat Transfer>Outflow. An Outflow node  is added to the Model Builder

10In the Graphics window, click the 
outlet boundary, Boundary 5, and 
right-click to add it to the 
Selection list. 
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The settings for the busbar, the bolts, and the Electric Potential 1 and 
Ground 1 boundaries have retained the correct selection, even though you 
added the box geometry for the air domain. To confirm this, click the 
Electric Potential 1 and the Ground 1 nodes in the Model Builder to verify 
that they have the correct boundary selection.

Continue with the flow settings. You need to indicate that fluid flow only takes 
place in the fluid domain and then set the inlet, outlet, and symmetry 
conditions.

1 In the Model Builder, click the Laminar Flow node . In the Laminar Flow 
settings window, click the Clear Selection button .

2 In the Graphics window click the air box (Domain 1) and right-click to add it 
to the Selection.
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It is good practice to verify that the Air 
material under the Materials node has all the 
properties that this multiphysics combination 
requires. In the Model Builder under 
Materials, click Air. In the  
Material settings window under Material 
Contents, verify that there are no missing 
properties, which are marked with a warning 
sign . The section “Materials” on page 13 
has more information. 
Continue with the boundaries.

3 In the Model Builder, right-click Laminar Flow  and at the boundary level 
select Inlet. An Inlet node  is added to the Model Builder. 

4 In the Graphics window, select the 
inlet (Boundary 2) and right-click 
to add it to the Selection list.

5 In the Inlet settings window under 
Velocity in the U0 field, enter Vin 
to set the Normal inflow velocity.
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6 Right-click Laminar Flow  and at 
the boundary level select Outlet . 
In the Graphics window, select the 
outlet (Boundary 5) and right-click 
to add it to the Selection list.
The last step is to add symmetry 
boundaries. You can assume that 
the flow just outside of the faces of 
the channel is similar to the flow 
just inside these faces. This is 
correctly expressed by the 
symmetry condition.

7 Right-click Laminar Flow  and 
select Symmetry. A Symmetry node 

 is added to the sequence.

8 In the Graphics window, click one of the blue faces in the figure (Boundaries 1, 
3, 4, or 48) and right-click each one to add all to the Selection list. 

Save the busbar_boxI.mph file, 
which now includes the Air material 
and Laminar Flow interface 
settings. 

When you know the 
boundaries, you can click the 
Paste button  and enter the 
information. In this example, 
enter 1,3,4,48 in the Paste 
selection window. Click OK 
and the boundaries are 
automatically added to the 
Selection list. 
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Coarsening the Mesh

In order to get a quick solution, the mesh is changed slightly and made coarser. 
The current mesh settings would take a relatively long time to solve, and you can 
always refine it later. 
1 In the Model Builder, expand the Mesh 1 node  and click the Size node .

2 In the Size settings window under 
Element Size, click the Predefined 
button and ensure that Normal is 
selected.

3 Click the Build All button . The geometry displays with a coarse mesh in the 
Graphics window. 

You can assume that the flow velocity is large enough to neglect the influence of 
the temperature increase in the flow field. 
It follows that you can solve for the flow field first and then solve for the 
temperature using the results from the flow field as input. This is implemented 
with a study sequence.
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Running a Study Sequence—Fluid Flow and Joule 
Heating

When the flow field is solved before the temperature field, it yields a weakly 
coupled multiphysics problem. The study sequence described in this section 
automatically solves such a weak coupling. 
1 In the Model Builder, right-click Study 1  and select Study Steps>Stationary 

 to add a second stationary study step to the Model Builder. 

Next, the correct physics needs to be connected with the correct study step. 
Start by removing Joule heating from the first step.

2 Under Study 1, click Step 1: Stationary .

3 In the Stationary settings window locate the Physics and Variables Selection 
section. In the Joule Heating (jh) row, click to change the check mark  to an 

 in the Solve for column, removing Joule Heating (jh) from Study 1. 
58 | Adding Physics to a Model



4 Repeat the step. Under Study 1 click Step 2: Stationary 1 . Under Physics and 
Variables Selection, in the Laminar Flow (spf) row click in the Solve for column 
to change the check mark  to an . 

5 Right-click the Study 1 node  and select Compute  (or press F8) to 
automatically create a new solver sequence that solves the two problems in 
sequence. 
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6 After the solution is complete, click the Transparency button  on the Graphics 
toolbar to visualize the temperature field inside the box.

The Temperature Surface plot that displays in the Graphics window shows the 
temperature in the busbar and in the surrounding box. You can also see that the 
temperature field is not smooth due to the relatively coarse mesh. A good 
strategy to get a smoother solution would be to refine the mesh to estimate the 
accuracy.

7 Save the busbar_box_I.mph file up to this point so you can return to this file 
if you want. The next steps use the original busbar.mph file.
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Parametric Sweeps

Sweeping a Geometric Parameter
It is often useful to generate multiple instances of a design with the objective to 
meet specific constraints. For the busbar, a design goal might be to lower the 
operating temperature. An alternative to cooling would be to decrease the current 
density. Since the current density depends on the geometry of the busbar, varying 
the width, wbb, should change the current density and, in turn, have some impact 
on the operating temperature. Let us run a parametric sweep on wbb to study this 
change. 

Adding a Parametric Sweep

1 Open the model file busbar.mph. In the Model Builder, right-click Study 1  
and select Parametric Sweep . A Parametric Sweep node is added to the Model 
Builder sequence.

2 In the Parametric Sweep settings 
window, under the table, click the 
Add button . From the Parameter 
names list in the table, select wbb. 
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3 Enter a range of Parameter values to sweep the width of the busbar from 5 cm 
to 10 cm with 1 cm increments. There are different ways to enter this 
information:
- Copy and paste or enter range(0.05,0.01,0.1) into the Parameter value 

list field.
- Click the Range  button and 

enter the values in the Range 
dialog box. In the Start field, 
enter 5e-2. In the Step field, 
enter 1e-2 and in the Stop field, 
enter 1e-1. Click Replace.

Next an Average Model Coupling 
is created, which can later be used 
to calculate the average 
temperature in the busbar.

4 Under Model 1, right-click Definitions  and select Model Couplings> 
Average . 

5 In the Average settings window select All domains from the Selection list. This 
creates an operator called aveop1. 

The aveop1 is now available to calculate the average of any quantity defined on 
those domains. A little later this is used to calculate the average temperature, but 
it can also be used to calculate average electric potential, current density, and so 
forth.

6 Right-click Study 1  and select Compute  to run the sweep. 
7 Select File>Save As to save the model with a new name, busbar_III.mph.
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Parametric Sweep Results

A Temperature (jh) 1 node is added under Results. 
The plot that displays in the Graphics window after the 
parametric sweep shows the temperature in the wider 
busbar using the last parameter value, wbb=0.1 m 
(10 cm). The plot is rather uniform in color, so change the 
maximum color range.

1 Under the Temperature (jh) 1 node, click the Surface node . 

2 In the Surface settings window, click 
Range to expand the section. Select 
the Manual color range check box. 
Enter 309.35 in the Maximum field 
(replace the default) to plot wbb at 10 
cm. 
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3 The Temperature (jh) 1 plot is updated in the Graphics window for  
wbb= 0.1 m (10 cm). 

Compare the wider busbar plot to the temperature for wbb=0.05 m (5 cm).

1 In the Model Builder, click the first Temperature (jh) node . 

2 In the 3D Plot Group settings 
window, select Solution 2 from the 
Data set list. This data set contains the 
results from the parametric sweep. 

3 In the Parameters value list, select 
0.05 (which represents wbb=5 cm). 
Click the Plot button . Click the 
Zoom Extents button  on the 
Graphics toolbar.
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The Temperature (jh) plot is updated for wbb= 0.05 m (5 cm). Note that you 
may have updated the color range for this plot already and then your plot may look 
different compared to the one below. If not, follow the steps below.

Like the wider busbar, the plot may be quite uniform in color, so change the 
maximum color range.
1 Under the first Temperature (jh) node, click the Surface node . 
2 In the Surface settings window, click Range to expand the section (if it is not 

already expanded). Select the Manual color range check box. 
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3 Enter 323 in the Maximum field (replace the default) to plot wbb at 5 cm. 
The Temperature (jh) plot is updated in the Graphics window for  
wbb= 0.05 m (5 cm). 

Click the first and second Temperature plot nodes to compare the plots in the 
Graphics window. The plots show that the maximum temperature decreases from 
331 K to 318 K as the width of the busbar increases from 5 cm to 10 cm. 
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Adding More Plots

To further analyze these results, you can plot the average temperature for each 
width.
1 Right-click Results  and add a 

1D Plot Group . 
2 In the 1D Plot Group settings 

window, select Solution 2 from the 
Data set list.  

3 In the Model Builder, right-click 1D Plot Group 4 and add a Global  node. 

4 Under y-Axis Data, click the first row in the Expressions column and enter 
aveop1(T). You use a similar syntax to calculate the average of other quantities. 

5 Click to expand the Legends section. Select the Expression check box.
This adds a legend at the top right corner of the graph.
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6 Click the Plot button  and save the busbar_III.mph model with these 
additional plots that use the parametric sweep results. 

In the plot, the average temperature also decreases as the width increases. This 
indicates that the goal of a lower operating temperature would be fulfilled by using 
a wider busbar.
The subject of parametric sweeps raises the question of parallel computing; it 
would be efficient if all parameters were solved simultaneously.
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Parallel Computing

COMSOL supports most forms of parallel computing including shared memory 
parallelism (for example multicore processors) and high performance computing 
(HPC) clusters.
You can use clusters to solve a series of parameter steps for a model, one parameter 
per node, or you can solve a single large model using distributed memory. For 
maximum performance, the COMSOL cluster implementation can utilize 
shared-memory multicore processing on each node in combination with the 
MPI-based distributed memory model. This brings a major performance boost by 
making the most out of the computational power installed.

Adding a Cluster Computing Job

Continue these steps using the busbar_III.mph model created in “Adding a 
Parametric Sweep” on page 61.
To run cluster simulations, you need to first enable the advanced options for the 
Job Configurations node. 
1 Click the Show button  on the Model Builder and select Advanced Study 

Options. 

2 In the Model Builder, under 
Study 1, right-click Job 
Configurations  and select 
Cluster Computing .
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The Cluster Computing settings window helps to manage the simulation either 
for running several instances of an identical parameterized model – one parameter 
value per host – or for running one parameter step in distributed mode. 

You choose the type of cluster job you want to do from the Cluster type list. 
COMSOL supports Windows Computer Cluster Server (WCCS) 2003, Windows 
HPC Server (HPCS) 2008, Open Grid Scheduler/ Grid Engine (OGS/GE), or 
Not distributed. 
To learn more about running COMSOL in parallel, see the COMSOL Installation 
and Operations Guide.
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Geometry Sequences

This section details how to create the busbar geometry using COMSOL’s 
geometry tools. The step-by-step instructions take you through the construction 
of the geometry using parameters set up in Global Definitions. Using 
parameterized dimensions helps to produce what-if analyses and geometric 
parametric sweeps.
Follow the steps under the Model Wizard (to add the physics and study) and 
Global Definitions (to add the parameters) starting with “Thorough Example: 
The Busbar” on page 5. Then return to this section to learn about geometry 
modeling. The first step in the geometry sequence is to draw the profile of the 
busbar.
1 Under Model 1, right-click  

Geometry 1  and select  
Work Plane . In the Work  
Plane settings window:
- Select xz-plane from the Plane list.
- Click the Show Work Plane button 

 on the settings toolbar.
Continue by editing the axis and grid 
settings in Work Plane 1.

2 In the Model Builder, expand the View 2 node  and click Axis .
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3 In the Axis settings window:
Under Axis:
- In the x minimum and y minimum 

fields, enter -0.01.
- In the x maximum and y maximum 

fields, enter 0.11.
Under Grid:
- Select the Manual Spacing check 

box.
- In the x spacing and y spacing 

fields, enter 5e-3.
4 Click the Apply button  on the 

toolbar. 

You can use interactive drawing to 
create a geometry using the drawing 
toolbar buttons while pointing and clicking in the Graphics window. You can also 
right-click the Plane Geometry node  under Work Plane 1  to add geometry 
objects to the geometry sequence.

In the next sequence of steps, we create a profile of the busbar.

Right-click the Geometry or 
Plane Geometry nodes to 
add geometry objects.

Click the Plane Geometry node 
under a Work Plane node 
to open the interactive drawing toolbar
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5 In the Model Builder under Work Plane 1, right-click Plane Geometry  and 
select Rectangle . 
In the Rectangle settings window 
under Size enter:
- L+2*tbb in the Width field
- 0.1 in the Height field 
Click the Build Selected button .

6 Create a second rectangle. Under 
Work Plane 1, right-click Plane 
Geometry  and select Rectangle . 
Under Size, enter:
- L+tbb in the Width field
- 0.1-tbb in the Height field
Under Position, enter:
- tbb in the yw field
Click the Build Selected button .

Use the Boolean Difference operation 
to subtract the second rectangle from 
the first one.  

7 Under Work Plane 1, right-click Plane Geometry  and select Boolean 
Operations>Difference . In the Graphics window, click r1 and right-click to 
add r1 to the Objects to add list in the Difference settings window.
To help select the geometry, you can display geometry labels in the Graphics 
window. In the Model Builder under Geometry 1>WorkPlane 1>Plane 
Geometry, click the View 2 node. Go to the View settings window and select 
the Show geometry labels check box.
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8 In the Difference settings window, 
click the Activate selection button  
to the right of the Objects to 
subtract list. Then select the smaller 
rectangle (left-click) and right-click 
to add r2 to the list. 
Click Build Selected .

Another way to select r2 in the 
Graphics window is to use the 
Selection List window. Select 
View>Selection List and in the 
Selection List settings window,  
click to highlight r2 (solid). Then 
right-click r2 (solid) in the list to add 
it to the Object to subtract list.

After building the selected geometry, you should have a backward-facing, 
L-shaped profile. Continue by rounding the corners of the L-shaped profile.
74 | Geometry Sequences



9 Under Work Plane 1, right-click Plane Geometry  and select Fillet . 
Select point 3 to add it to the Vertices to fillet list. There are different ways to 
add the points: 
- In the Graphics window, click point 3 (in the inner right corner), and 

right-click to add it to the Vertices to fillet list. 
- Select View>Selection List. In the Selection List window, click 3. The 

corresponding point is highlighted in the Graphics window. Click the Add to 
Selection button  on the Fillet settings window, or right-click in the 
Selection List.

10Enter tbb in the Radius field. Click Build Selected . 
This takes care of the inner corner.

11For the outer corner, right-click Plane 
Geometry  and select Fillet . 

12In the Graphics window, click point 
6, the outer corner, and right-click to 
add it to the Vertices to fillet list. 

13Enter 2*tbb in the Radius field. Click 
Build Selected .
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The result should match this figure:

Next you extrude the work plane to create the 3D busbar geometry.
1 In the Model Builder, right-click Work Plane 1  and select Extrude . In the 

Extrude settings window, enter wbb in the Distances from Plane table (replace 
the default) to extrude to the width of the profile. 

The table allows you to enter several values in order to create sandwich 
structures with different layer materials. In this case, only one extruded layer is 
needed.
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2 Click Build Selected  and then click the Zoom Extents  button on the 
Graphics toolbar. Click the Save button  and name the model busbar.mph (if 
you have not already done so). 

Next, create the titanium bolts by extruding two circles drawn in two  
work planes. 

3 In the Model Builder, right-click Geometry 1  and add a Work Plane . A 
Work Plane 2 node is added. In the Work Plane settings window, under Work 
Plane, select Face parallel as the Plane type.
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4 In the Graphics window, click face 8 (highlighted in the figure). Once this 
surface is highlighted in red, right-click anywhere in the Graphics window to 
add it to the Planar face list in the Work Plane settings window. 
Face number 8 is now highlighted in blue and the work plane is positioned on 
top of face number 8.

5 Click the Show Work Plane button  to draw the first circle representing the 
position of the first bolt. Click the Zoom Extents button  on the Graphics 
toolbar.

Face 8
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6 Under Work Plane 2, right-click 
Plane Geometry  and select 
Circle .
In the Circle settings window:
- Under Size and Shape in the 

Radius field, enter rad_1.
- Under Position, the xw and yw 

coordinates (0, 0) are already 
defined.

Click Build Selected . 

Continue creating the bolt by adding an extrude operation. 
1 In the Model Builder, right-click Work Plane 2  and select Extrude . In the 

Extrude settings window, in the first row of the Distances from Plane table, 
enter -2*tbb to extrude the circle a distance equal to the thickness  
of the busbar. 
Geometry Sequences | 79



2 Click the Build Selected button  to create the cylindrical part of the titanium 
bolt that runs through the busbar. 

Draw the two remaining bolts.
3 Right-click Geometry 1  and select Work Plane . A Work Plane 3 node is 

added. In the Work Plane settings window, for Work Plane 3, select Face parallel 
as the Plane type. 

4 In the Graphics window, click Face 4 (shown in the figure). When this surface 
is highlighted red, right-click anywhere in the Graphics window to add it to the 
Planar face list in the Work Plane settings window. 
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5 Click the Show Work Plane button  on the Work Plane settings window and 
the Zoom Extents button  on the Graphics toolbar to get a better view of the 
geometry. 
To parameterize the position of the two remaining bolts, add the circles that 
form the cross sections of the bolts.

6 Under Work Plane 3, right-click Plane Geometry  and select Circle . 
In the Circle settings window:
- Under Size and Shape, enter rad_1 

in the Radius field. 
- Under Position, enter  
-L/2+1.5e-2 in the xw field and 
-wbb/4 in the yw field. 

Click Build Selected .

Copy the circle that you just created 
to generate the third bolt in the 
busbar.

7 Under Work Plane 3, right-click 
Plane Geometry  and select 
Transforms>Copy . 

8 In the Graphics window, click the 
circle c1 to highlight it. Right-click 
anywhere in the Graphics window 
and add the circle to the Input object 
list in the Copy settings window. 

9 In the Copy settings window under 
Displacement, enter wbb/2 in the yw 
field.
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10Click Build Selected .
Your geometry, as shown in the workplane, should match this figure so far. 
Continue by extruding the circles.
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11In the Model Builder, right-click Work Plane 3  and select Extrude . In the 
Extrude settings window, in the first row of the Distances from Plane table, 
enter -2*tbb (replace the default). Click Build All . 

The geometry and its corresponding geometry sequence should match the 
figure. Click the Save button  and name the model busbar.mph.

To continue with the busbar tutorial, return to the section “Global 
Definitions” on page 8 to add the parameters to the busbar.mph  
model file.
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Easy Example: The Wrench

Torquing a Wrench
At some point in your life, it is likely you have tightened a bolt using a wrench. 
This exercise takes you through a model that analyzes this basic task, going into 
detail about the associated geometric tolerances, torque specifications, and the 
intrinsic contact problem.
In principle, a bolt replaces the need for external fastening by providing an internal 
clamping force via pretension. The tensile stress in a bolt is produced when it is 
torqued into a matching threaded hole or nut. The magnitude of this stress 
depends on many factors, such as material selection, assembly configuration, and 
lubrication.
Control of these parameters becomes the focus of much engineering effort, 
especially in critical applications such as automotive engines, brakes, aircraft, and 
structural installations. The following model presents both a bolt and a wrench at 
the moment of installation.
This tutorial is a short introduction to using COMSOL Multiphysics. Start by 
opening the Model Wizard and add a physics and a study, then import a geometry, 
open the Material Browser to add a material and examine the material properties. 
The other key steps to creating a model are then explored by defining a parameter, 
defining the boundary conditions, selecting geometric entities in the Graphics 
window, defining the Mesh and Study nodes, and finally examining the resulting 
plots.
If you prefer to practice with a more advanced model, read this section to 
familiarize yourself with some of the key features, and then go to the tutorial 
“Thorough Example: The Busbar” on page 5. 
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Model Wizard

1 Open the Model Wizard. To open the Model Wizard, double-click the 
COMSOL icon on the desktop. Or when COMSOL is already open:
- Click the New button  on the main toolbar
- Select File>New from the main menu
- Right-click the root node and select Add Model

2 In the Select Space Dimension window 
that opens, the 3D button is selected by 
default. Click Next .

3 In Add Physics, select Structural 
Mechanics > Solid Mechanics (solid) . 
Double-click or right-click to add it to the 
Selected physics section. Click Next . 
Another way to open the Add Physics 
window is to right-click the Model node 
and select Add Physics .

4 Click Stationary  under Preset Studies. 
Click the Finish button .
Preset Studies are studies that have solver 
and equation settings adapted to the 
selected physics, in this example, Joule 
heating.
Any selection from the Custom Studies 
branch  needs manual fine-tuning.
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Geometry

This tutorial uses a predefined geometry. To learn how to build your own 
geometry for the busbar model, see “Geometry Sequences” on page 71.

File Locations
For both the wrench and busbar tutorials in this guide, you can load predefined 
geometry or parameter files into COMSOL instead of manually adding the 
information. The location of the text and model files used in this exercise varies 
based on the software installation. For example, if the installation is on your hard 
drive, the file path might be similar to C:\Program Files\COMSOL43a\models\. 
1 Under Model 1, right-click Geometry 1  and select Import .

2 In the Import settings window, from the 
Geometry import list, select COMSOL 
Multiphysics file.

3 Click Browse and locate the file 
wrench.mphbin in the Model Library 
folder COMSOL_Multiphysics/
Structural_Mechanics. Double-click to 
add or click Open.
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4 Click Import to display the geometry in the Graphics window.

5 Click the Save button  on the main toolbar or select File>Save and name the 
model wrench.mph. Click the wrench geometry in the Graphics window and 
experiment with moving it around. As you click and right-click the geometry, 
it changes color. Click the Zoom In , Zoom Out , Go to Default 3D View 

, Zoom Extents , and Transparency  buttons on the toolbar to see what 
happens to the geometry.

- To rotate the busbar, left-click and drag it in the Graphics window
- To move it, right-click and drag
- To zoom in and out, center-click (and hold) and drag

Also see “Keyboard Shortcuts” on page 109 and “Working with 3D Geometry in 
the Graphics Window” on page 107 for additional information.

 

Rotate: Left-click and drag

Pan: Right-click and drag
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Materials

The Materials node  stores the material properties for all physics and all domains 
in a Model node. The chosen bolt material and tool steel are important 
characteristics of this contact problem. Here is how to choose them in COMSOL.
1 Open the Material Browser.

To open the Material Browser you can:
- Right-click Materials  in the 

Model Builder and select Open 
Material Browser 

- Select View>Material Browser

2 In the Material Browser, under 
Materials, expand the Built-In folder. 
Scroll down to find Structural Steel, 
right-click and select Add Material to 
Model.

3 Examine the Material 
Contents section to see 
how COMSOL categorizes 
available material 
information with respect to 
what the active physics 
requires.
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Also see the busbar tutorial sections “Materials” on page 13 and 
“Customizing Materials” on page 36 to learn more about working with 
the Material Browser.

Global Definit ions

Parameters
1 In the Model Builder, right-click Global Definitions  and choose  

Parameters .
2 Go to the Parameters settings window. Under Parameters in the Parameters 

table (or under the table in the fields), enter these settings: 
- In the Name column or field, enter F.
- In the Expression column or field, enter 150[N]. The Value column is 

automatically updated based on the expression entered. 
- In the Description column or field, enter Applied force.

In the busbar tutorial, the section “Global Definitions” on page 8 and 
“Parameters, Functions, Variables, and Model Couplings” on page 31 shows you 
more about working with parameters.
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So far, you have added the physics and 
study, imported a geometry, added the 
material and defined one parameter. The 
Model Builder node sequence should 
match the figure. The default feature 
nodes under Solid Mechanics are 
indicated by a ‘D’ in the upper left corner 
of the node icon.

Domain Physics and Boundary Conditions

With the geometry and materials defined, you are now ready to revisit the 
governing physics introduced in the Model Wizard section.
1 In the Model Builder, 

right-click Solid 
Mechanics (solid)  and 
at the boundary level, 
select Fixed Constraint .
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2 In the Graphics window, rotate the 
geometry by left-clicking and dragging 
into the position shown. Then left-click 
the cut-face of the partially modeled 
bolt (which turns the boundary red) 
and right-click to select it (which turns 
the boundary blue). 
Also see “Working with 3D Geometry 
in the Graphics Window” on page 107. 

3 Click the Go to Default 3D View button  on the Graphics toolbar to restore 
the geometry to the default view. 

4 In the Model Builder, right-click Solid Mechanics (solid)  and at the 
boundary level, select Boundary Load. A Boundary Load node  is added to 
the Model Builder sequence. 

5 In the Graphics window, click the 
Zoom Box button  on the toolbar 
and drag the mouse to highlight the 
area shown in the figure to the right. 
Release the mouse button. 
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6 Select the top socket face 
(Boundary 111) by left-clicking 
to highlight the boundary in red 
and right-clicking it to highlight it 
in blue and add it to the Selection 
list.

7 In the Boundary Load settings 
window, under Force, select Total 
force as the Load type and enter 
-F. The negative sign indicates the 
negative z direction (downward).

Mesh

Because the geometry contains small edges and faces, reduce the size of the 
minimum element. 
1 In the Model Builder, under Model 1 click Mesh 1 . In the Mesh settings 

window, under Mesh settings, from the Sequence type list select 
User-controlled mesh.
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2 Under Mesh 1 click the Size  node. 

The asterisks in the upper-right corner of the mesh nodes are dynamic feedback 
icons indicating that these nodes are being edited. 

3 In the Size settings window under 
Element Size, click the Custom 
button. 

4 Under Element Size Parameters, in 
the Minimum element size field, 
enter 0.0012. 

5 Click the Build All button  on the 
Size settings window toolbar.

After a few seconds, the mesh builds. 
Zoom in to the mesh and have a look 
at the distribution.
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Study

The following steps are needed to set up an iterative solver. By using such a solver, 
you can significantly reduce the memory amount needed for the calculations. If 
your computer has more than 2 GB of memory, you can go directly to the last step 
to compute the solution.
1 In the Model Builder, right-click Study 1  and choose  

Show Default Solver .
2 Expand the Study 1>Solver 

Configurations>Solver 1>  node.
3 Right-click Stationary Solver 1  and 

choose Iterative .
4 In the Iterative settings window, in the 

General section, select Right in the 
Preconditioning list.
This settings gives a more robust 
alternative to the Left preconditioning to 
the cost of a slightly increased 
computational time.

5 Right-click Iterative 1  and choose 
Multigrid .

6 Right-click Study 1  and select Compute 
 (or press F8).

After a few seconds of computation time, the default plot is displayed in the 
Graphics window. You can find other useful information about the computation 
by clicking the Messages and Log tabs under the Graphics window to see the 
kind of information available to you. These windows can also be opened from 
the main View menu.
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Displaying Results

The default von Mises stress is displayed in the Graphics window in a Surface plot 
with the displacement visualized using a Deformation subnode. Change the 
default unit (N/m2) to the more suitable MPa. 

1In the Model Builder, expand the Results>Stress 
(solid)  node, then click Surface 1 .

2In the settings 
window under Expression, from the 
Unit list select MPa (or enter MPa in the 
field).
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3 Click the Plot button  and the Zoom Extents button  on the Graphics 
toolbar. 

The plot is regenerated with the updated unit and shows the von Mises stress 
distribution in the bolt and wrench under an applied vertical load.
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Plotting the Principal  Strain Field 

Now determine the location of greatest tension by plotting the principal strain 
field.
1 Right-click the Results node  and add a 3D Plot Group .
2 Right-click the 3D Plot Group 2 node  and select Surface .

3 In the Surface settings window click the Replace Expression button  and 
select Solid Mechanics>Strain>Principal strains> First principal strain 
(solid.ep1). When you know the variable name, as in this exercise, you can also 
enter solid.ep1 in the Expression field. 
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4 Click the Plot button .
5 In the Model Builder, click 3D Plot Group 2. Press F2 and in the Rename 3D 

Plot Group window, enter First Principal Strain. Click OK.
Notice that the maximum principal strain is lower than 2%, a result that satisfies 
the small strain assumption. 

This concludes the wrench tutorial. The following sections provide you with some 
additional concepts to get you started with modeling in COMSOL.
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COMSOL Multiphysics—Additional Concepts

The next sections provide some additional concepts about working in COMSOL 
Multiphysics, including an explanation about geometric entities and what node 
types are shown to help you visualize your modeling. An introduction to the 
Model Builder and some of the terminology and navigation tools is included in 
the key to the table, and the last section describes the COMSOL Multiphysics file 
types.

About Geometric Entities and the Different Node Types
The Model Builder has many types of nodes to help you visualize the model 
structure. After you click the Finish button ( ) on the Model Wizard window, 
a Model node is added to the Model Builder based on the space dimension 
selected in the first step. 
The Model node has different images for each node’s space dimension. The nodes 
under the physics also indicate several things—the space dimension of the 
geometric entity applied to the node (at the domain, boundary, edge, or point 
level), and other useful pieces of information, such as whether it is a default node 
or a pair. The geometric entity name varies based on space dimension, but the 
nodes clearly indicate the type of node you are working with. Also see “Working 
with 3D Geometry in the Graphics Window” for some more information about 
geometric entities and how to move and rotate geometry in the Graphics window.

 GEOMETRIC ENTITY NAMES IN DIFFERENT SPACE DIMENSIONS

ENTITY DIMENSION NAME IN 3D NAME IN 2D NAME IN 1D NAME IN 0D

3D domain — — —

2D boundary domain — —

1D edge boundary domain —

0D vertex vertex boundary domain
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Several additional node types are available that show node dependencies and 
status. They are described in the following sections. 

EXCLUSIVE NODES

The use of an exclusive node means that only one node can be active for a given 
selection. That is, if you add another exclusive node (for example, an identical 
feature node) with the same selection, the first exclusive node is overridden and 
thus has no effect.
Typical exclusive nodes include model equations, initial values, and boundary 
conditions that are constraints, such as prescribed values for displacements, 
temperatures, pressures, and so on, including special variants of these such as 
ground conditions in electromagnetics and fixed constraints in structural 
mechanics. Also some boundary conditions that are not constraints but have a 
definitive meaning are exclusive nodes—for example, electric insulation, thermal 
insulation, and no-flow conditions. 

OVERRIDDEN AND OVERRIDING NODES

Depending on the selections for each node, an exclusive node can override 
another node partially. Nodes are exclusive only within their specific physics. 
When a node is selected in the Model Builder tree, nodes that are overridden by 
the selected node are indicated by this icon ( ), and nodes that override the 
selected node are indicated by this icon ( ).

 NODE ICONS IN DIFFERENT SPACE DIMENSIONS.

SPACE DIMENSION DOMAIN BOUNDARY EDGE POINT DEFAULT 
NODE 
EXAMPLE

PAIR

 3D

 2D —

 2D 
axisymmetric

—

 1D — —

 1D 
axisymmetric

— —

 0D not applicable
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CONTRIBUTING NODES

A contributing node ( ) means you can have several of these nodes with the 
same selection—the software adds these together when evaluating the model. 
Typical contribution nodes are loads, fluxes, and source terms, where you can have 
more than one of each type that is active on the same domain or boundary.

OTHER NODE TYPES

Other indicators show the status of nodes (is the node current, being built, or 
edited?) or alert you to problems (error and warning nodes).

TYPE EXAMPLE DESCRIPTION

Current node A current node is used for Geometry and Meshing nodes and 
indicates that the feature or sequence of steps has been built. 
It is a green line on the left and upper edges of the node. 

Current node, 
but not built

This node is current, but not yet built, for example, on a 
Geometry node. It is a brown line on the left and upper edges 
of the node. This example is also displaying the asterisk 
indicating the node is being edited. 

Editing, or in 
process of 
editing, a node

An edited node has a blue asterisk (star) in the upper right 
corner of the node, for example, on a Mesh node. The 
asterisk also appears on plot nodes when the plot has not 
been updated to reflect changes in the data or settings (for 
example after re-solving).

Warning A warning does not prevent the completion of a task but it 
might affect the accuracy or other aspects of the model. When 
there is a yellow triangle with an exclamation mark in the 
lower right corner of the node, a warning appears. Other 
warnings typically appear in the Log window.

Error (indicator) An error prevents the program from completing a task. For 
many error types, a red X is added to the lower right-hand 
corner of the node where the error is occurring. For example, 
on a Material node, to indicate that information is missing. 

Error (node) An error prevents the program from completing a task. This is 
an error subnode which contains an error message that 
generally provide additional information. It is a node with an X 
in a red circle, for example, under a Solver node. 
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PLOT AND PLOT GROUP NODES

There are too many plot types to list here. We will just mention that the icons are 
color coded to show space dimension of the plot: 
• 3D Plot Group icons are blue.
• 2D Plot Group icons are pink. 
• 1D Plot Group icons are green.
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An Overview of the Model Builder
This figure shows you the final node sequence you have completed for the first 
part of this tutorial for the basic Busbar model. 
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The table below gives some more information regarding the Model Tree.

 KEY TO THE MODEL BUILDER

This is the window name with the toolbar underneath. Right-click any 
window to detach, move, size, minimize, and maximize it. Click and 
hold the mouse button down to drag the window and reposition it in the 
COMSOL Desktop. 

The model file name is the Root node. Click this node to edit the default 
unit system and see details about the model. Right-click to add 
additional Models or Studies. If a model thumbnail is created (as in the 
section “Creating Model Images from Plots” on page 29) this is where 
you see the image when the Root node is clicked.

The icon next to Model 1 shows that it is a 3D model. The icon changes 
based on the space dimension (see “About Geometric Entities and the 
Different Node Types” on page 99). Click the Model node to edit the 
model identifier and settings or right-click the node to Add Physics (and 
open the Model Wizard) and to add additional Mesh nodes.

The Definitions and Global Definitions node (under the Root node) are 
where you can define features with a local or global scope, respectively. 
In this tutorial, there are several sections where you learn about these 
features—“Global Definitions” on page 8, “Defining Functions” on 
page 31, and “Defining Model Couplings” on page 34 introduce you to 
some of the features.

The Geometry node contains a sequence of nodes, or steps, that in this 
case create the geometry displayed in the Graphics window. It is the same 
sequence of nodes completed in the section “Geometry Sequences” on 
page 71. 

Click the Materials node to open the Material settings window and get 
an overview of the materials contained in the model. Right-click the 
Materials node to open the Material Browser and define the materials. 
Click the nodes under Materials to view, add, and edit the material 
properties and contents, or change the appearance of the material in the 
Graphics window. See “Material Properties and Libraries” on page 36 
for more information about this node.

A physics node. In this example Joule Heating has been added to the 
model using the Model Wizard. Right-click the node to open the context 
menu to add additional domain, boundary, edge, point, and pair nodes 
to the model. In the section “Adding Physics to a Model” on page 41 
you learn more about working with more than one interface. 
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The physics nodes that you see in the Model Builder can tell you many 
things. This node tells you three things—it is a default node (a D on the 
icon) at the boundary level for a 3D model. See “About Geometric 
Entities and the Different Node Types” on page 99 for examples in other 
space dimensions.

The Mesh node contains the sequences of mesh operations that defines 
the computational meshes for the model. When there is only one mesh 
in the model, its Mesh node appears directly under the Model node. In 
the section “Meshing Sequences” on page 38 you learn more about this 
feature.
For this, and all nodes, right-click to rename a node (or press F2) and 
view the node Properties, for example.

When you select any of the predefined study types in the Model Wizard, 
a Study node is added to the Model Builder as well as the corresponding 
study step or steps. 
Most study steps are used to control the form of the equations, which 
physics are included and which meshes are used. These study steps 
correspond to a part of a solver sequence, which contains nodes that 
define variables to solve for, the solvers and their settings, and additional 
sequence nodes for storing the solution, for example. The section 
“Running a Study Sequence—Fluid Flow and Joule Heating” on page 
58 shows you the power of these features.
Right-click the Study node to Compute the solution and add additional 
Study Steps, as is done in the section “Study” on page 24, for example.

The Results node has all the features you need during results analysis and 
visualization. These main operation features are available: data sets, plots 
and plot groups, derived values, tables, the ability to export data and 
images, and to generate reports. Right-click any of these nodes to open 
the corresponding context menu, as shown in the section “Results” on 
page 24.

Click the plot nodes under Results to view the final result in the Graphics 
window. Like the nodes under the physics, both the Plot Group and 
individual plot icons indicate the space dimension, as well as what plot 
type is being used, as described in “About Geometric Entities and the 
Different Node Types” on page 99. Right-click the Plot Groups to add 
additional plots or images to reports.

 KEY TO THE MODEL BUILDER
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COMSOL File Formats
When you are ready to save your model, there are three COMSOL Multiphysics 
model file formats to choose from—MPH-files, Model Java-files, and Model 
M-files.
COMSOL MPH-Files are the default standard file with the extension .mph. The 
file contains both binary and text data. The mesh and solution data are stored as 
binary data, while all other information is stored as plain text. You can quickly save 
and load MPH-files. All the models in the COMSOL Multiphysics Model Library 
and the model libraries in the add-on modules are MPH-files. See “The Model 
Library” for more information.
Model Java-Files are editable script files, with the extension .java, that contain 
sequences of COMSOL Multiphysics commands as Java code. You can compile 
these Java files and run them as separate applications. Edit the files in a text editor 
to add additional commands.
Model M-files are editable script files, similar to the Model Java-files, for use with 
MATLAB. Model M-files, which have the extension .m, contain a sequence of 
COMSOL Multiphysics commands as a MATLAB M-file. Run the Model M-files 
in MATLAB like any other M-file scripts. Also edit the files in a text editor to 
include additional COMSOL Multiphysics commands or general MATLAB 
commands. Running files in the Model M-file format requires the COMSOL 
LiveLink™ for MATLAB®. 
Also see “Supported External File Formats” for more information about all the 
other formats supported by COMSOL.
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Working with 3D Geometry in the Graphics Window

There are toolbar buttons, mouse click options, window settings, and keyboard 
shortcuts available to help move, select, and highlight geometric entities. Often 
there is more than one way to do the same thing. In COMSOL, every level of 
geometry can be treated individually.
COMSOL Multiphysics highlights geometric entities at different stages of 
selection. Selected lines also have a thicker line width and selected points are 
larger. Each geometric entity is highlighted in a sequence—red, blue, green, or 
with no highlight— to indicate its status. It cycles between red (left-click to select 
the geometric entity), blue (right-click to add it to the selection), green (left-click 
to show that it is added), and no highlight (right-click to cancel the selection). The 
table below lists the many ways to move and rotate the geometry. 

TASK ACTION AND RESULT OPERATION ORDER

Rotate the geometry about the 
axes:

Left-click and hold down the mouse 
button while dragging it in any 
direction.

This rotates the scene around the axes 
parallel to the screen X- and Y-axes 
with origin in the scene rotation point.

left-click

Move the visible frame on the 
image plane in any direction, 
(like using a camera shift lens):

Right-click and hold down the mouse 
button while dragging it in any 
direction.

right-click

Rotate about the X- and Y axes 
in the image plane (tilt and pan 
the camera):

Press Ctrl and left-click. While holding 
down both buttons, drag the mouse in 
any direction.

This places the rotation coordinate 
system in the camera and rotates 
around the axes parallel to the screen 
X- and Y-axes.

Ctrl+left-click

Move the camera in the plane 
parallel to the image plane:

Press Ctrl and right-click. While holding 
down both buttons, drag the mouse in 
any direction. 

Ctrl+right-click

Rotate the camera around the 
axis:

Press Ctrl+Alt, then left-click. While 
holding down all buttons, drag the 
mouse in any direction. 

Ctrl+Alt+ 
left-click

Move the scene in the plane 
orthogonal to the direction the 
camera looks at:

Right-click then press Ctrl. While 
holding down both buttons, drag the 
mouse in any direction. 

right-click+Ctrl
Working with 3D Geometry in the Graphics Window | 107



Move the scene in the plane 
orthogonal to the axis between 
the camera and the scene 
rotation point:

Right-click the mouse and press Alt. 
While holding down both buttons, 
drag the mouse in any direction. 

right-click+Alt

Move the camera into and away 
from the object (dolly in/out):

Click the middle mouse button and 
then press Ctrl. While holding down 
both buttons, drag the mouse in any 
direction. 

middle-click+Ctrl

Rotate the camera about its axis 
between the camera and the 
scene rotation point (roll 
direction):

Press Alt, then left-click. While holding 
down both buttons, drag the mouse in 
any direction.

Alt+left-click

Move the camera along the axis 
between the camera and the 
scene rotation point:

Press Alt, then middle-click. While 
holding down both buttons, drag the 
mouse in any direction.

 Alt+middle-click

TASK ACTION AND RESULT OPERATION ORDER
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Keyboard Shortcuts

SHORTCUT (WINDOWS, LINUX) SHORTCUT (MAC) ACTION

F1 F1 Display help for the selected node 
or window

Ctrl+F1 Command+F1 Open the COMSOL 
Documentation front page in an 
external window

F2 F2 Rename the selected node, file, or 
folder

F3 F3 Disable selected nodes

F4 F4 Enable selected nodes

F5 F5 Update solution

F7 F7 Build the selected node in the 
geometry and mesh branches, or 
compute to the selected node in the 
solver sequence.

F8 F8 Build the geometry, build the mesh, 
compute the entire solver sequence, 
update results data, or update the 
plot

Del Del Delete selected nodes

Left arrow (Windows); Shift 
+ left arrow (Linux)

Left arrow Collapse a branch in the Model 
Builder

Right arrow (Windows); Shift 
+ right arrow (Linux)

Right arrow Expand a branch in the Model 
Builder

Up arrow Up arrow Move to the node above in the 
Model Builder

Down arrow Down arrow Move to the node below in the 
Model Builder

Alt+left arrow Ctrl+left arrow Move to the previously selected 
node in the Model Builder

Alt+right arrow Ctrl+right arrow Move to the next selected node in 
the Model Builder

Ctrl+A Command+A Select all domains, boundaries, 
edges, or points; select all cells in a 
table
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Ctrl+D Command+D Deselect all domains, boundaries, 
edges, or points

Ctrl+C Command+C Copy text in fields

Ctrl+V Command+V Paste copied text

Ctrl+Z Command+Z Undo the last operation

Ctrl+Y Ctrl+Shift+Z Redo the last undone operation

Ctrl+up arrow Command+up arrow Move a definitions node, geometry 
node, physics node (except default 
nodes), material node, mesh node, 
study step node, or results node up 
one step

Ctrl+down arrow Command+down 
arrow

Move a definitions node, geometry 
node, physics node (except default 
nodes), material node, mesh node, 
study step node, or results node 
down one step

Ctrl+Tab Ctrl+Tab Switch focus to the next window on 
the desktop

Ctrl+Shift+Tab Ctrl+Shift+Tab Switch focus to the previous 
window on the desktop

Ctrl+Alt+left arrow Command+Alt+left 
arrow

Switch focus to the Model Builder 
window

Ctrl+Alt+right arrow Command+Alt+right 
arrow

Switch focus to the settings window

Ctrl+Alt+up arrow Command+Alt+up 
arrow

Switch focus to the previous section 
in the settings window

Ctrl+Alt+down arrow Command+Alt+down 
arrow

Switch focus to the next section in 
the settings window

Shift+F10 or

(Windows only) Menu key

Ctrl+F10 Open the context menu

Ctrl+Space Ctrl+Space Open list of predefined quantities 
for insertion in Expression fields for 
plotting and results evaluation.

SHORTCUT (WINDOWS, LINUX) SHORTCUT (MAC) ACTION
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Finding More Information

When COMSOL Multiphysics is open, the Help feature for context-sensitive help 
opens the Help window inside the COMSOL Desktop. The Help window has a 
short description of the feature node selected in the Model Builder. The window 
also has links to more information and access to all the online help documentation.
To open context-sensitive help:
• Press F1 (Windows, Mac, and Linux)
• Click the Help button  on the main toolbar or from any settings window
• Right-click any node and select Help from the context menu, or
• Select Help>Help from the main menu

After opening the Help window, click any node in the Model Builder to access the 
description of the node. Then follow the links or enter a search term to find out 
more.
To open the full documentation set, which is searchable and available in PDF and 
HTML formats:
• Press Ctrl+F1 (Windows and Linux) or Command+F1 (Mac),
• Click the Documentation  button on the main toolbar, or
• Select Help>Documentation from the main menu

Then either enter a search term or navigate the Contents for a specific module in 
the documentation tree. Note that It can take up to a minute for the Help window 
to load and process the index the first time it is activated but after this it will load 
quickly. Also see the COMSOL Multiphysics User’s Guide for more details.
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The Model Library

To open the Model Library, select View>Model Library ( ) from the main 
menu, and then search by model name or browse under a module folder name. 
Click to highlight any model of interest, and select Open Model and PDF to open 
both the model and the documentation explaining how to build the model. 
Alternatively, click the Help button ( ) or select Help>Documentation in 
COMSOL to search by model name or browse by module.
The Model Library is updated on a regular basis by COMSOL. Choose 
View>Model Library Update ( ) to update the model library. This connects you 
to COMSOL’s Model Update website where you can access the latest models and 
model updates. This may typically include models that have been added or 
improved after the latest product release.
The MPH-files in the COMSOL model libraries can have two formats—Full 
MPH-files or Compact MPH-files.
• Full MPH-files include all meshes and solutions. In the Model Library these 

models appear with the  icon. If the MPH-file’s size exceeds 25MB, a 
tooltip with the text “Large file” and the file size appears when you position 
the cursor at the model’s node in the Model Library tree.

• Compact MPH-files include all settings for the model but have no built 
meshes and solution data to save space on the DVD (a few compact 
MPH-files have no solutions for other reasons). You can open these models 
to study the settings and to mesh and re-solve the models. It is also possible 
to download the full versions—with meshes and solutions—of most of these 
models through Model Library Update. In the Model Library such models 
appear with the  icon. If you position the cursor at a compact model in 
the Model Library window, a No solutions stored message appears. If a full 
MPH-file is available for download, the corresponding node’s context menu 
includes a Model Library Update item.
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Supported External File Formats

After completing a design study as you have done, you often want to use the 
results in some other context. For instance, you may want to output an optimal 
geometry in a dedicated CAD format. In fact, the broadly applicable nature of 
multiphysics simulation brings with it the need for interaction with many other 
scientific computing platforms. For this reason, COMSOL Multiphysics provides 
the capability to read and write an array of file formats. The list below contains 
several formats that are compatible with COMSOL. These formats are categorized 
according to the associated type of software.
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MCAD

FILE FORMAT READ WRITE

AutoCAD® (.dwg, 3D only)1 Yes6 Yes6

Autodesk Inventor® (.ipt,.iam)2 Yes Yes6

Creo™ Parametric (.prt, .asm)2 Yes Yes6

Pro/ENGINEER® (.prt, .asm)2 Yes Yes6

Solid Edge® (.par, .asm)3 Yes6 Yes6

SolidWorks® (.sldprt, .sldasm)2 Yes Yes6

SpaceClaim® (.scdoc)4 Yes6 Yes6

DXF (.dxf, 2D only) Yes Yes

Parasolid® (.x_t, xmt_txt, .x_b, .xmt_bin)2 Yes Yes

ACIS® (.sat, .sab)2 Yes No

Step (.STEP)2 Yes No

IGES (.IGES)2 Yes No

CATIA® V5 (.CATPart, .CATProduct)5 Yes No

VRML, v1 (.vrml, .vrl) Yes No

STL (.stl) Yes Yes
1Requires LiveLink™ for AutoCAD®

2Requires one of the LiveLink™ products for AutoCAD®, Creo™ Parametric, 
Inventor®, Pro/ENGINEER®, SolidWorks®, or SpaceClaim®; or the CAD Import 
Module
3Requires LiveLink™ for Solid Edge®

4Requires LiveLink™ for SpaceClaim®

5Requires the CAD Import Module (or one of the LiveLink™ products for 
AutoCAD®, Creo™ Parametric, Inventor®, Pro/ENGINEER®, SolidWorks®, or 
SpaceClaim®) and the File Import for CATIA® V5
6From/To file via linked CAD package
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ECAD

MATERIAL DATABASES

MESH

FILE FORMAT READ WRITE

NETEX-G (.asc)1 Yes No

ODB++(X) (.xml)1 Yes No

GDS (.gdx)1 Yes No

SPICE (.cir)2 Yes No
1Requires the ECAD Import Module 
2Requires one of the AC/DC, RF, or MEMS Modules

FILE FORMAT READ WRITE

NASA file (.dat)1 Yes No

CHEMKIN (.dat)1 Yes No

CAPE-OPEN1 (direct connection) n/a n/a

LXCAT file (.lxcat)2 Yes No
1Requires Chemical Reaction Engineering Module
2Requires Plasma Module

FILE FORMAT READ WRITE

NASTRAN Bulk Data (.nas, .bdf, .nastran, .dat) Yes No

VRML, v1 (.vrml, .vrl) Yes No

STL (.stl) Yes Yes
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NUMERICAL DATA, IMAGES, AND MOVIES

PROGRAMMING LANGUAGES

INTERPOLATION DATA FORMATS

FILE FORMAT READ WRITE

Plain text (.txt) Yes Yes

Comma-separated values (.csv) Yes Yes

Copy and paste spreadsheet format Yes Yes

Excel® spreadsheet (.xlsx)1 Yes Yes

JPEG (.jpg) Yes Yes

PNG (.png) Yes Yes

BMP (.bmp) Yes Yes

GIF (.gif) Yes No

EPS (.eps) (1D graphs) No Yes

DEM (.dem) Yes No

Animated GIF (.gif) No Yes

Adobe® Flash (.swf) No Yes

AVI (.avi)2 No Yes
1Requires LiveLink™ for Excel®

2Available for Windows only

FILE FORMAT READ WRITE

MATLAB®: Model M-File (.m)1 Yes Yes

MATLAB®: Function (.m)1 Yes No

Java: Model Java File (.java) Yes Yes

C: Function Yes No
1Requires LiveLink™ for MATLAB®

FILE FORMAT READ WRITE

Spreadsheet1 Yes Yes

Grid Yes No

Sectionwise Yes Yes
1.xlsx-files requires LiveLink™ for Excel®
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BUILT-IN FUNCTIONS

FUNCTION ARGUMENTS AND DEFINITION CALL

Analytic The function name is its identifier, 
for example an1.

The function is a mathematical 
expression of its arguments.

Example: Given the arguments x 
and y, its definition is 
sin(x)*cos(y).

The function has arbitrary number 
of arguments.

The name of the function with 
comma-separated arguments within 
parenthesis. For example:

an1(x,y)

Elevation The function name is its identifier, 
for example elev1.

Used to import geospatial elevation 
data from digital elevation models 
and map the elevation data to a 
function of x and y. A DEM file 
contains elevation data for a portion 
of the Earth’s surface. The resulting 
function behaves essentially like a 
grid-based interpolation function.

The name of the function with

comma-separated arguments within

parenthesis. For example:

elev1(x,y)

Gaussian Pulse The function name is its identifier, 
for example gp1.

The Gaussian pulse function defines 
a bell-shaped curve according to the 
expression

It is defined by the mean parameter, 
x0, and the standard deviation, σ.

The function has one argument.

The name of the function with a 
single argument within parenthesis. 
For example:

gp1(x)

Image The function name is its identifier, 
for example im1.

Used to import an image (in BMP, 
JPEG, PNG, or GIF format) and map 
the image’s RGB data to a scalar 
(single channel) function output 
value. By default the function’s 
output uses the mapping (R+G+B)/
3.

The name of the function with

comma-separated arguments within

parenthesis. For example:

im1(x,y)

y x( ) 1
σ 2π
---------------e

x x0–( )2–

2σ2
------------------------

=
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Interpolation The function name is its identifier, 
for example int1.

An interpolation function is defined 
by a table or file containing the 
values of the function in discrete 
points.

The file formats are the following: 
spreadsheet, grid, or sectionwise.

The function has one to three 
arguments.

The name of the function with 
comma-separated arguments within 
parenthesis. For example:

int1(x,y,z)

Piecewise The function name is its identifier, 
for example pw1.

A piecewise function is created by 
splicing together several functions, 
each defined on one interval. Define 
the argument, extrapolation and 
smoothing methods, and the 
functions and their intervals. 

This function has one argument with 
different definitions on different 
intervals, which must not overlap or 
have any holes between them. 

The name of the function with a 
single argument within parenthesis. 
For example:

pw1(x)

Ramp The function name is its identifier, 
for example rm1.

A ramp function is a linear increase 
with a user-defined slope that begins 
at some specified time. 

The function has one argument. It 
can also be smoothed.

The name of the function with a 
single argument within parenthesis. 
For example:

rm1(x)

Random The function name is its identifier, 
for example rn1.

A random function generates white 
noise with uniform or normal 
distribution and has one or more 
arguments to simulate white noise.

The function has arbitrary number 
of arguments.

The name of the function with 
comma-separated arguments within 
parenthesis. For example:

rn1(x,y)
The arguments x and y are used as a 
random seeds for the random 
function.

FUNCTION ARGUMENTS AND DEFINITION CALL
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Rectangle The function name is its identifier, 
for example rect1.

A rectangle function is 1 in an 
interval and 0 everywhere else.

The function has one argument.

The name of the function with a 
single argument within parenthesis. 
For example:

rect1(x)

Step The function name is its identifier, 
for example step1.

A step function is a sharp transition 
from 0 to some other value 
(amplitude) at some location.

The function has one argument. It 
can also be smoothed.

The name of the function with a 
single argument within parenthesis. 
For example:

step1(x)

Triangle The function name is its identifier, 
for example tri1.

A triangle function is a linear 
increase and linear decline within an 
interval and 0 everywhere else. 

The function has one argument. It 
can also be smoothed.

The name of the function with a 
single argument within parenthesis. 
For example:

tri1(x)

Waveform The function name is its identifier, 
for example wv1.

A waveform function is a periodic 
function with one of several 
characteristic shapes: sawtooth, sine, 
square, or triangle.

The function has one argument. It 
can also be smoothed.

The name of the function with a 
single argument within parenthesis. 
For example:

wv1(x)

FUNCTION ARGUMENTS AND DEFINITION CALL
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Working with LiveLink™ Add-Ons

The following table shows the options to start COMSOL and the different linked 
partner software using the LiveLink add-ons.

COMSOL® 
Product

Can Start COMSOL 
from Partner Software

Can Start Partner Software 
from COMSOL

Can Connect 
Running Sessions

LiveLink™  
for Excel®

Yes1 Yes2 No

LiveLink™ 
for MATLAB®

Yes3 Yes4 Yes5

LiveLink™  
for AutoCad®

No No Yes

LiveLink™  
for Creo™ Parametric

No No Yes

LiveLink™  
for Inventor®

No No Yes

LiveLink™  
for Pro/ENGINEER®

No No Yes

LiveLink™  
for Solid Edge®

No No Yes

LiveLink™  
for SolidWorks®

- Bidirectional Mode No No Yes

- Onewindow Mode Yes No No

LiveLink™  
for SpaceClaim®

No No Yes

1 When you open a COMSOL model from Excel, a COMSOL model window starts and a link is established 
automatically. The COMSOL model window is an output window that displays geometry, mesh, and results.
2 A COMSOL model that includes a table reference to an Excel spreadsheet automatically starts an Excel 
process in the background when the model is run in COMSOL Desktop.
3 You can start a COMSOL Server from a MATLAB session using the "system" command and then connect 
to it using "mphstart" in the MATLAB command prompt.
4 The "COMSOL 4.3a with MATLAB" desktop shortcut starts COMSOL Server and MATLAB, then 
connects them automatically. When you run a COMSOL model in COMSOL Desktop that includes a 
MATLAB function (Global Definitions>Functions), a MATLAB engine and connection is started 
automatically.
5 You can connect a MATLAB session to a running COMSOL Server using the COMSOL command 
"mphstart" in the MATLAB command prompt.
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