Cyclic Voltammetry Study Limited to 10000 seconds

Please login with a confirmed email address before reporting spam

I'm trying to run cyclic voltammetry study with 100successive cycles. However, at scan rate = 4mV/s, at scanning potential E_vertex1 =1V & E_vertex2 = 2V (1 cycle at 4mV/s scan rate = 500s). The maximum cycles that the study completes is only 20 cycles (10,000s).

When I try increasing the scan rate to 10mV/s with a goal of performing 100 successive voltammetry cycles, the comsol study ends at 50 cycles (still at 10000s).

Is there a way I can increase the allowable time to perform cyclic voltammetry greater than 10000s?

Thank you for your help.


3 Replies Last Post Nov 2, 2020, 10:29 PM EST
Robert Koslover Antennas, Waveguides, Electromagnetics

Please login with a confirmed email address before reporting spam

Posted: 4 weeks ago Oct 30, 2020, 10:10 PM EDT
Updated: 4 weeks ago Oct 30, 2020, 10:12 PM EDT

Note: The easiest way for you to help others to help you to diagnose a problem in your model is for you to post your model to the forum, so the details of it can be examined.

Now, without your model file to look at, here's my wild guess: In time-domain models, you normally have to specify (such as under Settings/Time Dependent --> Study Settings) the times of interest. The default (on my system) is typically range(0,0.1,1). So, if I didn't change that setting, my time-domain simulations would run from t=0 to t=1.0s. You say that yours is consistently terminating at t = 10,000s. Perhaps this may seem like a trivial question, but what did you specify for the range of times that you actually wanted for the simulation to run? Do you, by some chance, have it set to 10000s? If so... well, that would explain a lot! But if not, then... maybe you could post your file to the forum?

Best regards.

Note: The easiest way for you to help others to help you to diagnose a problem in your model is for you to post your model to the forum, so the details of it can be examined. Now, *without* your model file to look at, here's my wild guess: In time-domain models, you normally have to specify (such as under Settings/Time Dependent --> Study Settings) the times of interest. The default (on my system) is typically *range(0,0.1,1)*. So, if I didn't change that setting, my time-domain simulations would run from t=0 to t=1.0s. You say that yours is consistently terminating at t = 10,000s. Perhaps this may seem like a trivial question, but *what did you specify* for the range of times that you actually *wanted* for the simulation to run? Do you, by some chance, have it set to 10000s? If so... well, that would explain a lot! But if not, then... maybe you could post your file to the forum? Best regards.

Please login with a confirmed email address before reporting spam

Posted: 4 weeks ago Nov 2, 2020, 8:30 PM EST

Yeah I agree time dependent studies has default settings. But in my case, I did not have a chance to set this time given that I'm running cyclic voltammetry studies( see attached screenshots for the some of the configurations).

In this kind of simulation, you set the linear sweep rate, vertex potentials 1&2 and the number of cycles you will run your simulation.

In a cyclic voltammetry, 1 cycle represents 1 forward and reverse sweep (i.e Vertex 1 -> Vertex 2 -> Vertex 1). So in effect, the time to complete 1 cycle at 4mV/s rate is equivalent to

note: It is multiplied by 2 to cover the reverse scan.

At , the total time must be 50000s, however as I said before, I cannot run simulation greater than 10000s, making the solver fails to reach the target 100cycles at 4mV/s(only 20cycles at 10000s). I don't know if this is set as default in comsol but I'm not using Time dependent on my studysteps so I guess the problem is elsewhere.

Thank you for your help.

Regards,

Paul

Note: The easiest way for you to help others to help you to diagnose a problem in your model is for you to post your model to the forum, so the details of it can be examined.

Now, without your model file to look at, here's my wild guess: In time-domain models, you normally have to specify (such as under Settings/Time Dependent --> Study Settings) the times of interest. The default (on my system) is typically range(0,0.1,1). So, if I didn't change that setting, my time-domain simulations would run from t=0 to t=1.0s. You say that yours is consistently terminating at t = 10,000s. Perhaps this may seem like a trivial question, but what did you specify for the range of times that you actually wanted for the simulation to run? Do you, by some chance, have it set to 10000s? If so... well, that would explain a lot! But if not, then... maybe you could post your file to the forum?

Best regards.

Yeah I agree time dependent studies has default settings. But in my case, I did not have a chance to set this time given that I'm running cyclic voltammetry studies( see attached screenshots for the some of the configurations). In this kind of simulation, you set the linear sweep rate, vertex potentials 1&2 and the number of cycles you will run your simulation. In a cyclic voltammetry, 1 cycle represents 1 forward and reverse sweep (i.e Vertex 1 -> Vertex 2 -> Vertex 1). So in effect, the time to complete 1 cycle at 4mV/s rate is equivalent to t = 2*\frac{E_{vertex2}-E_{vertex1}}{sweep_{rate}} t = 2*\frac{2V-1V}{0.004V/s} t = 500s note: It is multiplied by 2 to cover the reverse scan. At n_{cycles}=100, the total time must be **50000s**, however as I said before, I cannot run simulation greater than 10000s, making the solver fails to reach the target 100cycles at 4mV/s(only 20cycles at 10000s). I don't know if this is set as default in comsol but I'm not using Time dependent on my studysteps so I guess the problem is elsewhere. Thank you for your help. Regards, Paul >Note: The easiest way for you to help others to help you to diagnose a problem in your model is for you to post your model to the forum, so the details of it can be examined. > >Now, *without* your model file to look at, here's my wild guess: In time-domain models, you normally have to specify (such as under Settings/Time Dependent --> Study Settings) the times of interest. The default (on my system) is typically *range(0,0.1,1)*. So, if I didn't change that setting, my time-domain simulations would run from t=0 to t=1.0s. You say that yours is consistently terminating at t = 10,000s. Perhaps this may seem like a trivial question, but *what did you specify* for the range of times that you actually *wanted* for the simulation to run? Do you, by some chance, have it set to 10000s? If so... well, that would explain a lot! But if not, then... maybe you could post your file to the forum? > >Best regards.


Please login with a confirmed email address before reporting spam

Posted: 4 weeks ago Nov 2, 2020, 10:29 PM EST
Updated: 4 weeks ago Nov 2, 2020, 11:43 PM EST

Thank you for your help, I solve the issue following your suggestion. It turns out by default, the maximum timestep in the time-dependent solver for Cyclic voltammetry is set to 0 1e4(see attached screenshot). I was able to change it by manually defining the solver.

Yeah I agree time dependent studies has default settings. But in my case, I did not have a chance to set this time given that I'm running cyclic voltammetry studies( see attached screenshots for the some of the configurations).

In this kind of simulation, you set the linear sweep rate, vertex potentials 1&2 and the number of cycles you will run your simulation.

In a cyclic voltammetry, 1 cycle represents 1 forward and reverse sweep (i.e Vertex 1 -> Vertex 2 -> Vertex 1). So in effect, the time to complete 1 cycle at 4mV/s rate is equivalent to
t = 2\frac{E_{vertex2}-E_{vertex1}}{sweep_{rate}} t = 2\frac{2V-1V}{0.004V/s} t = 500s

note: It is multiplied by 2 to cover the reverse scan.

At n_{cycles}=100, the total time must be 50000s, however as I said before, I cannot run simulation greater than 10000s, making the solver fails to reach the target 100cycles at 4mV/s(only 20cycles at 10000s). I don't know if this is set as default in comsol but I'm not using Time dependent on my studysteps so I guess the problem is elsewhere.

Thank you for your help.

Regards,

Paul

Note: The easiest way for you to help others to help you to diagnose a problem in your model is for you to post your model to the forum, so the details of it can be examined.

Now, without your model file to look at, here's my wild guess: In time-domain models, you normally have to specify (such as under Settings/Time Dependent --> Study Settings) the times of interest. The default (on my system) is typically range(0,0.1,1). So, if I didn't change that setting, my time-domain simulations would run from t=0 to t=1.0s. You say that yours is consistently terminating at t = 10,000s. Perhaps this may seem like a trivial question, but what did you specify for the range of times that you actually wanted for the simulation to run? Do you, by some chance, have it set to 10000s? If so... well, that would explain a lot! But if not, then... maybe you could post your file to the forum?

Best regards.

Thank you for your help, I solve the issue following your suggestion. It turns out by default, the maximum timestep in the time-dependent solver for Cyclic voltammetry is set to 0 1e4(see attached screenshot). I was able to change it by manually defining the solver. >Yeah I agree time dependent studies has default settings. But in my case, I did not have a chance to set this time given that I'm running cyclic voltammetry studies( see attached screenshots for the some of the configurations). > >In this kind of simulation, you set the linear sweep rate, vertex potentials 1&2 and the number of cycles you will run your simulation. > >In a cyclic voltammetry, 1 cycle represents 1 forward and reverse sweep (i.e Vertex 1 -> Vertex 2 -> Vertex 1). So in effect, the time to complete 1 cycle at 4mV/s rate is equivalent to >t = 2*\frac{E_{vertex2}-E_{vertex1}}{sweep_{rate}} >t = 2*\frac{2V-1V}{0.004V/s} >t = 500s > >note: It is multiplied by 2 to cover the reverse scan. > >At n_{cycles}=100, the total time must be **50000s**, however as I said before, I cannot run simulation greater than 10000s, making the solver fails to reach the target 100cycles at 4mV/s(only 20cycles at 10000s). I don't know if this is set as default in comsol but I'm not using Time dependent on my studysteps so I guess the problem is elsewhere. > >Thank you for your help. > >Regards, > >Paul > > > > >>Note: The easiest way for you to help others to help you to diagnose a problem in your model is for you to post your model to the forum, so the details of it can be examined. >> >>Now, *without* your model file to look at, here's my wild guess: In time-domain models, you normally have to specify (such as under Settings/Time Dependent --> Study Settings) the times of interest. The default (on my system) is typically *range(0,0.1,1)*. So, if I didn't change that setting, my time-domain simulations would run from t=0 to t=1.0s. You say that yours is consistently terminating at t = 10,000s. Perhaps this may seem like a trivial question, but *what did you specify* for the range of times that you actually *wanted* for the simulation to run? Do you, by some chance, have it set to 10000s? If so... well, that would explain a lot! But if not, then... maybe you could post your file to the forum? >> >>Best regards.

Reply

Please read the discussion forum rules before posting.

Please log in to post a reply.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.