Note: This discussion is about an older version of the COMSOL Multiphysics® software. The information provided may be out of date.

Discussion Closed This discussion was created more than 6 months ago and has been closed. To start a new discussion with a link back to this one, click here.

Help Needed: Comsol solving Error

Hi
I am new to Comsol Multiphysics 4.2a. I built a model & try to run it but after clicking compute and it gave me an error
specifying

the following feature has encountered a problem:
-Feature: Stationary Solver 1 (sol1/s1)
-Error: Unknown Function.



3 Replies Last Post Aug 15, 2012, 1:43 AM EDT
Posted: 5 years ago Aug 14, 2012, 3:06 PM EDT
Hi,

Maybe you should check again your inputs (function expression, parameter, variables....),

And this link below hopes to help you: www.comsol.com/community/forums/general/thread/25832/
Hi, Maybe you should check again your inputs (function expression, parameter, variables....), And this link below hopes to help you: http://www.comsol.com/community/forums/general/thread/25832/

Posted: 5 years ago Aug 14, 2012, 9:04 PM EDT
Hi , the Model I built is somehow running after checking the function and variable function. But my Variable expression has actually the rate expression where one of the concentration term (cD) is raised to 7.5(fraction) . How to write this term fraction in Comsol Multiphysics 4.2a. If I use the fraction term, the comsol is not able to evaluate the expression. if I am making it a whole number 8, then I am getting wrong result and concentration profile is not converging for any reactant & product.

here is my Rate expression which I am writing in variables.

rA=((-k)*(cA-(cC^3*cD^8/Kp/cB^4))/(1+(10^5*cC^3*cD^7.5/cB^4)+(cC*cD^2/cB))).

I am attaching the model build up file, made in Comsol 4.2a , please check if any other error is there which is giving problem.

Hi , the Model I built is somehow running after checking the function and variable function. But my Variable expression has actually the rate expression where one of the concentration term (cD) is raised to 7.5(fraction) . How to write this term fraction in Comsol Multiphysics 4.2a. If I use the fraction term, the comsol is not able to evaluate the expression. if I am making it a whole number 8, then I am getting wrong result and concentration profile is not converging for any reactant & product. here is my Rate expression which I am writing in variables. rA=((-k)*(cA-(cC^3*cD^8/Kp/cB^4))/(1+(10^5*cC^3*cD^7.5/cB^4)+(cC*cD^2/cB))). I am attaching the model build up file, made in Comsol 4.2a , please check if any other error is there which is giving problem.


Posted: 5 years ago Aug 15, 2012, 1:43 AM EDT
Hi

are you getting an "unit" warning flag (equation in orange) or a typo error (equation in red) ?

because the units will get wring if you use such fractions of powers, but that is a warning, and COMSOL is calculating correctly.

I suspect it's in fact your equation that is not fully respecting the transfer of units, formally there is a unit conversion term missing

--
Good luck
Ivar
Hi are you getting an "unit" warning flag (equation in orange) or a typo error (equation in red) ? because the units will get wring if you use such fractions of powers, but that is a warning, and COMSOL is calculating correctly. I suspect it's in fact your equation that is not fully respecting the transfer of units, formally there is a unit conversion term missing -- Good luck Ivar

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.