NaN or Inf found when solving linear system using PARDISO.

Please login with a confirmed email address before reporting spam

Hello,

I am running a 3D stationary model that includes flow+HT+surface-to-surface radiation nodes. There are two domains (solid inside a fluid domain(gas)). There is an inlet/oulet in the domain while a heater is generating heat inside the solid domain. Heat needs to be ejected via radiation and convection from the system.

I can run flow node separately. I can run HT in solid and fluid+radiation nodes separately.

When I want to run all at the same time, I get "- Detail: NaN or Inf found when solving linear system using PARDISO."

This should relate to coupling between flow and heat. I am not sure how to tackle this issue. I have used ramping/auxiliary sweep but with no luck.

I appreciate any hints.


0 Replies Last Post Aug 17, 2022, 6:45 a.m. EDT
COMSOL Moderator

Hello Hooman E

Your Discussion has gone 30 days without a reply. If you still need help with COMSOL and have an on-subscription license, please visit our Support Center for help.

If you do not hold an on-subscription license, you may find an answer in another Discussion or in the Knowledge Base.

Reply

Please read the discussion forum rules before posting.

Please log in to post a reply.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.