Note: This discussion is about an older version of the COMSOL Multiphysics® software. The information provided may be out of date.

Discussion Closed This discussion was created more than 6 months ago and has been closed. To start a new discussion with a link back to this one, click here.

Comsol 4.3a Memory problem -- not using enough RAM

Hello everyone,

Usually the complain is that Comsol is using too much memory, but in my case its other way round.


I have a really nice machine in the lab with windows 8 server. I have Comsol version 4.3a installed. I am trying to run an RF module computation, where I am trying to create a fine mesh.

My problem is that even though the computer has 256 GB or RAM, the comsol uses only 1.2 GB or so maximum. Also, I have a 16 core x 2 processor but it uses only 3.5% of the cpu at max.

Coule anyone please explain to me if there is a way to overcome this problem. did anyone else have the same problem?

Thanks in advance.

8 Replies Last Post Jan 26, 2015, 3:49 PM EST
Posted: 5 years ago Feb 4, 2013, 1:06 AM EST
Hi

Check the earlier threads, some solvers cannot use multiprocessing, and several operations are not paralellised, or cannot easily be made so. By default COMSOL will choose at much RAM required and available, and use at least half of all your processors

--
Good luck
Ivar
Hi Check the earlier threads, some solvers cannot use multiprocessing, and several operations are not paralellised, or cannot easily be made so. By default COMSOL will choose at much RAM required and available, and use at least half of all your processors -- Good luck Ivar

Posted: 5 years ago Feb 4, 2013, 9:51 AM EST
So in order to use multiple processors, I checked the options of Comsol and changed the number of processors from 1 to the value I have and it seems like it can use many processors. Nevertheless, for the meshing, it still uses around 700MB maximum. At the bottom it always stays

Working set: around 670MB | virtual 780MB.

After changing the number of processors, the cpu %age went up but after 5 minuts the cpu usage stays between 2.5% to 3% and of course it takes forever to mesh. My first trial of meshing is still not done.

Any help would be greatly appreciated.

Thanks Mr. Ivar Kjelberg for your quick response!

So in order to use multiple processors, I checked the options of Comsol and changed the number of processors from 1 to the value I have and it seems like it can use many processors. Nevertheless, for the meshing, it still uses around 700MB maximum. At the bottom it always stays Working set: around 670MB | virtual 780MB. After changing the number of processors, the cpu %age went up but after 5 minuts the cpu usage stays between 2.5% to 3% and of course it takes forever to mesh. My first trial of meshing is still not done. Any help would be greatly appreciated. Thanks Mr. Ivar Kjelberg for your quick response!

Anosh Daruwalla
Posted: 4 years ago Jun 12, 2013, 2:53 PM EDT
I am facing a similar problem for the transient solver. Any solution or further update on this issue would be greatly appreciated :)
I am facing a similar problem for the transient solver. Any solution or further update on this issue would be greatly appreciated :)

Felipe Beltran-Mejia
Posted: 4 years ago Jun 13, 2013, 12:22 PM EDT
Hi All,

In this entry: www.comsol.com/support/knowledgebase/830/

Comsol's staff give some advices such as augmenting the Java Heap Memory, which is the place where the different solutions are stored.

To my surprise, I've found out the default value for the Java Heap Size is quite low (1Gb). They recommend doubling it, but I had went further and multiplyed it by a factor of 10. Altough it didn't seems to change much (at least for me).
--
cheers,
Felipe BM
Hi All, In this entry: http://www.comsol.com/support/knowledgebase/830/ Comsol's staff give some advices such as augmenting the Java Heap Memory, which is the place where the different solutions are stored. To my surprise, I've found out the default value for the Java Heap Size is quite low (1Gb). They recommend doubling it, but I had went further and multiplyed it by a factor of 10. Altough it didn't seems to change much (at least for me). -- cheers, Felipe BM

Gunnar Andersson COMSOL Employee
Posted: 4 years ago Jun 14, 2013, 2:23 AM EDT

Comsol's staff give some advices such as augmenting the Java Heap Memory, which is the place where the different solutions are stored.


This isn't quite correct: The solutions are not stored in the Java heap. If you increase the Java heap a lot, then you will decrease the memory that can be used for solving the model - quite the opposite of what you want.

In general, I advice you to not experiment with the Java heap settings unless you have received from support to do so.


[QUOTE] Comsol's staff give some advices such as augmenting the Java Heap Memory, which is the place where the different solutions are stored. [/QUOTE] This isn't quite correct: The solutions are not stored in the Java heap. If you increase the Java heap a lot, then you will decrease the memory that can be used for solving the model - quite the opposite of what you want. In general, I advice you to not experiment with the Java heap settings unless you have received from support to do so.

Felipe Beltran-Mejia
Posted: 4 years ago Jun 14, 2013, 7:29 AM EDT
Thanks for the feedback Gunnar.

Then I believe the referenced knowledgebase shall be corrected, since (for me) that is what it says:

"Of the available memory (RAM and virtual memory), one section, the Java heap, is reserved for Java and will be used for storing the different solutions in the model.( ...) The rest of the memory will be available for meshing and solving. (....)"

Thanks for claryfying, I'll return my confs to their default values.
--
cheers,
Felipe BM
Thanks for the feedback Gunnar. Then I believe the referenced knowledgebase shall be corrected, since (for me) that is what it says: "Of the available memory (RAM and virtual memory), one section, the Java heap, is reserved for Java and will be used for storing the different solutions in the model.( ...) The rest of the memory will be available for meshing and solving. (....)" Thanks for claryfying, I'll return my confs to their default values. -- cheers, Felipe BM

James D Freels
Posted: 4 years ago Jun 15, 2013, 12:07 PM EDT
Is your machine a 32-bit or 64-bit ? If a 64-bit, is your OS setup to run in 64-bit ?

In order for a single application, e.g. COMSOL, to use a lot of memory, both the hardware and OS must be running in 64-bit mode. Otherwise, the most memory ANY application, including COMSOL, can use in 32-bit mode is 2^31 or about 2GB or less. This sounds like what you may be doing.

If all is running 64-bit, make sure if you are running Windows, you click the 64-bit COMSOL start icon and not the 32-bit COMSOL start icon.

Is your machine a 32-bit or 64-bit ? If a 64-bit, is your OS setup to run in 64-bit ? In order for a single application, e.g. COMSOL, to use a lot of memory, both the hardware and OS must be running in 64-bit mode. Otherwise, the most memory ANY application, including COMSOL, can use in 32-bit mode is 2^31 or about 2GB or less. This sounds like what you may be doing. If all is running 64-bit, make sure if you are running Windows, you click the 64-bit COMSOL start icon and not the 32-bit COMSOL start icon.

Jorge Hernandez
Posted: 3 years ago Jan 26, 2015, 3:49 PM EST
Hi all,
What happens is that your solver is saving files in order to save RAM.
If this is not desirable ( you have tons of RAM and you find it faster, like me) then you can un-check the option of "store solution out-of-core" box, it is in your "Time dependent solver" options.
Hope this helps!
if you do this, and then you figure out how to clear the memoru without having to close and open again the server I would be very grateful.
Best,
Hi all, What happens is that your solver is saving files in order to save RAM. If this is not desirable ( you have tons of RAM and you find it faster, like me) then you can un-check the option of "store solution out-of-core" box, it is in your "Time dependent solver" options. Hope this helps! if you do this, and then you figure out how to clear the memoru without having to close and open again the server I would be very grateful. Best,

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.