Note: This discussion is about an older version of the COMSOL Multiphysics® software. The information provided may be out of date.

Discussion Closed This discussion was created more than 6 months ago and has been closed. To start a new discussion with a link back to this one, click here.

Mesh creation

Hello,

I have a problem with mesh generation. I set up the model and then mesh it. but when I want to run the study at first step it re-generate the mesh.
I don't know what is the reason. my model divided to a lot of grids, so mesh generation is a time consuming step.

thanks in advance for your help.
Saeed

6 Replies Last Post Apr 22, 2013, 11:09 AM EDT
Posted: 4 years ago Apr 19, 2013, 2:02 PM EDT
Hi

could it be that you have turned ON the mesh refinement or automatic remeshing feature in the solver tab ?

--
Good luck
Ivar
Hi could it be that you have turned ON the mesh refinement or automatic remeshing feature in the solver tab ? -- Good luck Ivar

Posted: 4 years ago Apr 20, 2013, 11:53 PM EDT
Hi Ivar,

Thanks, But I didn't select re-meshing. I create mesh with special size but when I run the study it starts with creating free mesh. it takes a lot of time and some times it ends with error :"A problem occurred when building mesh feature 'Reference 1/Free Tetrahedral 1'.Failed to generate mesh for domain.".

thanks again for your help.
Saeed.
Hi Ivar, Thanks, But I didn't select re-meshing. I create mesh with special size but when I run the study it starts with creating free mesh. it takes a lot of time and some times it ends with error :"A problem occurred when building mesh feature 'Reference 1/Free Tetrahedral 1'.Failed to generate mesh for domain.". thanks again for your help. Saeed.

Posted: 4 years ago Apr 21, 2013, 10:09 AM EDT
Hi

if you have meshed fully the model, manually, it should not remesh at solver start, it's only if you have meshed part that it might remesh but it could also state: warning (domains not meshed) or something close,if you have not meshed all domains.
Are you sure that your domains are well meshed, and its not that you have only meshed the edges, or the boundaries but not the domains ?

Check the mesh statistics if they look coherent

--
Good luck
Ivar
Hi if you have meshed fully the model, manually, it should not remesh at solver start, it's only if you have meshed part that it might remesh but it could also state: warning (domains not meshed) or something close,if you have not meshed all domains. Are you sure that your domains are well meshed, and its not that you have only meshed the edges, or the boundaries but not the domains ? Check the mesh statistics if they look coherent -- Good luck Ivar

Posted: 4 years ago Apr 22, 2013, 1:59 AM EDT
Hi Ivar,

Thanks for your time and help,
actually I use Finer grid and my domain divided to around 2 mil. grids, but when I start run it begins with creating free mesh, and finally total no. of grids are 1.5 mil. grids.
unfortunately I don't know how to check the quality of my grid. I would be thank full if you introduce me a reference about that.

thanks,
Hope the best,
Saeed.

Hi Ivar, Thanks for your time and help, actually I use Finer grid and my domain divided to around 2 mil. grids, but when I start run it begins with creating free mesh, and finally total no. of grids are 1.5 mil. grids. unfortunately I don't know how to check the quality of my grid. I would be thank full if you introduce me a reference about that. thanks, Hope the best, Saeed.

Posted: 4 years ago Apr 22, 2013, 3:19 AM EDT
Hi

right click the mesh node and choose "statistics"

Normally it should not re-mesh at solver start, if the mesh is already done, so something must be wrong, but no idea what it can be ;(

--
Good luck
Ivar
Hi right click the mesh node and choose "statistics" Normally it should not re-mesh at solver start, if the mesh is already done, so something must be wrong, but no idea what it can be ;( -- Good luck Ivar

Posted: 4 years ago Apr 22, 2013, 11:09 AM EDT
Hi Ivar,
Thank for your help
Hi Ivar, Thank for your help

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.