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F i x e d -B ed R e a c t o r  f o r  C a t a l y t i c  
Hyd r o c a r b on Ox i d a t i o n

Introduction

This example treats the partial oxidation of o-xylene in air to phthalic anhydride (PA) 
in a multitube fixed-bed reactor—the dominating process for producing this 
important industrial chemical.

In this process, temperature is usually kept between 400–475 °C and the residence 
time varies between 0.5–5 seconds. The catalyst of choice is usually a mix of vanadium 
oxide and potassium sulfate on a silica support. The most important factor to consider 
for this process is the temperature inside the reactor. The reactions taking place in the 
reactor are highly exothermic, and the reactor needs to be cooled to avoid runaway 
conditions. The temperature distribution also affects phthalic anhydride yield. It is 
possible to control the temperature distribution by varying tube diameter, residence 
time, wall temperature (cooling rate), and the inlet temperature of the feed. This 
example covers some of these factors by creating a detailed model of the system using 
the 2D pseudo-homogeneous model as described in the literature (Ref. 3, and Ref. 4). 

Tubular reactors are usually modeled with the assumption that concentration and 
temperature gradients only occur in the axial direction. The only transport mechanism 
operating in this direction is the overall flow itself, which is considered to be of 
plug-flow type, that is, all the fluid elements are assumed to move with a uniform 
velocity along parallel streamlines. This example takes a more general approach by 
accounting for variations of the concentrations and the temperature in the axial 
direction. Through the use of effective diffusivities and conductivities, the model also 
includes the mixing in the axial direction that occurs in a reactor as a result of 
turbulence and the presence of packing.

Model Definition

Assume rotational symmetry to set up a 2D axisymmetric model.

The reaction kinetics of the rather complex process under study can, to a satisfactory 
degree, be described by the scheme in Figure 1 (References 1–4).
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Figure 1: Reaction paths. A represents o-xylene, B refers to phthalic anhydride, and C is 
the total amount of carbon monoxide and carbon dioxide.

Owing to a very high excess of oxygen, the reactions are pseudo-first-order. It follows 
that the reaction rates can be described by the equations

 (1)

where ρb is the catalyst bulk density (kg/m3), y0 is the mole fraction of oxygen, yA0 is 
the inlet mole fraction of o-xylene, xA is the total conversion of o-xylene, and xB is the 
conversion of o-xylene into phthalic anhydride (similarly, xC represents the total 
conversion into carbon monoxide and carbon dioxide). In the above equations, the 
conversions are dimensionless and the reaction rates have the SI unit mol/(m3·s).

The rate coefficients (mol/(kg catalyst·s) depend on temperature as described by the 
Arrhenius law

 (2)

where T is the reactor temperature, and Ai and Bi are characteristic parameters for each 
reaction (i = 1, 2, 3).

A schematic description of the reactor is given in Figure 2. The convective flow of gas 
takes place from the bottom to the top. Axisymmetry is assumed, which reduces the 
3D geometry to two dimensions.
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Figure 2: Schematic representation of the reactor.

The design equations for this system—a mass transport equation and an energy 
transport equation—read (Ref. 3 and Ref. 4)

 (3)

Here us is the superficial velocity (m/s), ctot is the total concentration (mol/m3), ρg 
denotes the gas density (kg/m3), yA0 is the inlet mole fraction of o-xylene, λeff 
represents the bed’s effective thermal conductivity (W/(m·K)), and ΔHi is the 
enthalpy of adsorption for reaction i. Because xA = xB + xC, it is only necessary to solve 
two mass transport equations, which results in the following design equations:

 (4)

The rate equations can be rewritten accordingly:
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 (5)

The boundary conditions for this system are as follows (see Figure 2 for the 
appropriate references):

 (6)

At the reactor inlet, the concentrations are zero and the temperature equals T0. At the 
outlet, assume that the convective parts of the mass transport and the heat transport 
dominate.

Results and Discussion

A temperature plot (Figure 3) shows a maximum not far from the reactor inlet.

Figure 3: Temperature distribution across the tubular half plane.
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This so-called hotspot is a common phenomenon for systems with exothermic 
reactions to which cooling is applied. Also, note that the radial temperature gradients 
are quite large around this hotspot.

Figure 4 shows the composition in the reactor along the axial direction. The graphs 
give the bulk mean conversions for an inlet temperature of 627 K (354 °C). You can 
see from the middle line that the phthalic anhydride production rate falls off somewhat 
along the tube, which is a typical behavior for consecutive reactions.

Figure 4: Composition versus axial coordinate in the reactor.

In Figure 5, note that the radial temperature gradients are quite severe, as the 
temperature along the symmetry axis is well above the mean temperature. On the basis 
of this information you can draw the conclusion that a 1D model with axial mixing 
would not be good enough to describe this system.
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Figure 5: Temperature versus radial coordinate in the reactor (z=0.6 m) for a number of 
inlet of different inlet temperatures.

A parameter study of the inlet temperature gives the results displayed in Figure 6 for 
the average temperature along the reactor centerline. As this figure shows, the reactor’s 
inlet temperature affects the centerline temperature quite dramatically. A high 
temperature increases the production rate of phthalic anhydride, but it can also 
increase the production of carbon monoxide and carbon dioxide. Furthermore, too 
high a temperature might be detrimental to the catalyst, which means that good 
control of the reactor’s feed temperature is essential.
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Figure 6: Average temperature along the reactor centerline vs. axial coordinate for 
different inlet temperatures.

Although the results presented here describe the process running at steady-state, the 
model can be easily generalized to a time-dependent version for use in automatic 
control and start-up simulations.

Modeling in COMSOL Multiphysics

To make use of the unit-handling capabilities that COMSOL Multiphysics offers, use 
cB ≡ xB ctot and cC ≡ xC ctot as the basic dependent variables in place of the 
dimensionless conversions xB and xC. For the latter, as well as for xA = xB + xC, define 
scalar expressions to use for postprocessing. Furthermore, make the mean conversions 
over a circular cross section of the tube of area A = π R2,

,  (7)

available for postprocessing by defining corresponding projection coupling variables.
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Model Library path: Chemical_Engineering_Module/
Transport_and_Reactions/fixed_bed_reactor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, click the Multiphysics button, and set the Space dimension list 
to Axial symmetry (2D). 

3 Select Chemical Engineering Module>Mass Transport>Convection and Diffusion from 
the Application Modes list. In the Dependent variables edit field type cB cC (space 
separated) and in the Application mode name edit field type massbal.

4 Click the Add button.

5 Select Chemical Engineering Module>Energy Transport>Convection and Conduction 
from the Application Modes list. Name the application mode energybal and leave 
the dependent variables to the default, T. Click Add.

6 Click OK to close the Model Navigator.
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G E O M E T R Y  M O D E L I N G

1 Click the Rectangle/Square button on the Draw toolbar and draw a rectangle of 
arbitrary dimension. Double-click on the rectangle and type the values listed below 
in the corresponding edit fields; when done, click OK.

2 Double-click the EQUAL button on the status bar at the bottom of the user interface 
to allow for different scales on the r- and z-axes.

3 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

Constants
1 In the Options>Constants dialog box, define the constants listed in the following 

table. You can either type them in or import them from a file included in the 
Chemical Engineering Module. To do the latter, click the Import Variables From File 
button, browse to the folder listed in the Model Library path on page 8, select the 
file fixed_bed_reactor_const.txt, and then click Open.

PROPERTY VALUE

Width 0.0127

Height 3

Base Corner

r 0

z 0

NAME EXPRESSION DESCRIPTION

R 1.27[cm] Tube radius

D_eff 3.19e-7[m^2/s] Effective diffusion constant

u_s 1.064[m/s] Superficial velocity

rho_b 1300[kg/m^3] Catalyst bulk density

k_eff 0.779[W/(m*K)] Effective thermal conductivity

C_p 1046[J/(kg*K)] Fluid heat capacity

rho_g 1.293[kg/m^3] Gas density

c_tot 44.85[mol/m^3] Total concentration

alpha 156[W/(m^2*K)] Heat transfer coefficient

T0 627[K] Inlet temperature

DeltaH1 -1.285[MJ/mol] Enthalpy of adsorption, reaction 1

DeltaH2 -3.276[MJ/mol] Enthalpy of adsorption, reaction 2
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2 Click OK.

Scalar Expressions
1 Define the following expressions in the Options>Expressions>Scalar Expressions 

dialog box, either by typing them in or by importing them from the file 
fixed_bed_reactor_expr.txt, which you find in the same directory as the 
constants text file.

2 Click OK.

Projection Coupling Variables
Next, define the mean conversions (see Equation 7) as projection coupling variables 
and make them available on the reactor centerline, which corresponds to Boundary 1. 
(For information on coupling variables in COMSOL Multiphysics, see the section 

DeltaH3 DeltaH1+DeltaH2 Enthalpy of adsorption, reaction 3

yA0 0.00924 Inlet mole fraction of o-xylene

y0 0.208 Mole fraction of oxygen

A1 1[kmol/kg]*exp(19.837)/1[h] Pre-exponential factor, reaction 1

A2 1[kmol/kg]*exp(20.86)/1[h] Pre-exponential factor, reaction 2

A3 1[kmol/kg]*exp(18.97)/1[h] Pre-exponential factor, reaction 3

B1 13588[K] Activation temperature, reaction 1

B2 15803[K] Activation temperature, reaction 2

B3 14394[K] Activation temperature, reaction 3

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION DESCRIPTION

k1 A1*exp(-B1/T) Forward rate constant, reaction 1

k2 A2*exp(-B2/T) Forward rate constant, reaction 2

k3 A3*exp(-B3/T) Forward rate constant, reaction 3

r1 rho_b*yA0*y0*k1*(1-xB-xC) Reaction rate, reaction 1 (A->B)

r2 rho_b*yA0*y0*k2*xB Reaction rate, reaction 2 (B->C)

r3 rho_b*yA0*y0*k3*(1-xB-xC) Reaction rate, reaction 3 (A->C)

rB r1-r2 Net production rate of phthalic 
anhydride

rC r2+r3 Production rate of carbon oxides

xA (cB+cC)/c_tot Conversion, species A

xB cB/c_tot Conversion, species B

xC cC/c_tot Conversion, species C
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“Using Coupling Variables” on page 255 of the COMSOL Multiphysics User’s 
Guide.)

1 From the Options menu, select Projection Coupling Variables>Subdomain Variables.

2 On the Source page, select Subdomain 1 from the Subdomain selection list.

3 On the first empty row in the table, type xA_mean in the Name column and (2/
R^2)*r*xA in the Expression column. (Use the default integration order.)

4 Click the General transformation option button. In the Source transformation area, 
set x to z and y to r.

5 On the Destination page, select Boundary from the Level list.

6 Select Boundary 1 as well as the Use selected boundaries as destination check box.

7 In the Destination transformation area, set x to r.

8 Click the Source tab.

9 Repeat Steps 3–8 twice to define xB_mean and xC_mean as the radial mean values of 
the conversions xB and xC, respectively.

10 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Mass Transport
1 From the Multiphysics menu, select 1 Convection and Diffusion (massbal).

2 From the Physics menu, select Subdomain Settings. Select Subdomain 1.
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3 Specify the following subdomain settings:

4 On the cB and cC pages, in turn, click the Artificial Diffusion button. Select the 
Streamline diffusion check box. Click OK to confirm the default parameters.

5 Click OK in the Subdomain Settings dialog box.

Boundary Conditions—Mass Transport
1 Choose Physics>Boundary Settings.

2 On both the cB and the cC page, specify the following boundary conditions:

On Boundaries 1 and 4, the default Insulation/Symmetry condition applies.

3 Click OK.

Subdomain Settings—Energy Transport
1 From the Multiphysics menu, select 2 Convection and Conduction (energybal).

2 Choose Physics>Subdomain Settings.

3 For Subdomain 1, enter the settings listed in the following table:

4 Click the Artificial Diffusion button, then select the Streamline diffusion check box. 
Click OK to confirm the default parameters and close the dialog box.

5 On the Init page, set T(t0) to T0.

SPECIES CB CC

D (isotropic) D_eff D_eff

R rB/yA0 rC/yA0

u 0 0

v u_s u_s

SETTINGS BOUNDARY 2 BOUNDARY 3

Type Concentration Convective flux

cB0, cC0 0

PROPERTY VALUE

 k (isotropic) k_eff

 ρ rho_g

 Cp C_p

 Q (-DeltaH1)*rB+(-DeltaH3)*rC

 u 0 u_s
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6 Click OK.

Boundary Conditions—Energy Transport
1 Choose Physics>Boundary Settings.

2 Enter boundary conditions according to the following table:

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Finer.

Because of the large aspect ratio of the model geometry—the reactor is 3 meters 
long and 0.0127 meters in radius—it is necessary to rescale the mesh in the radial 
direction; use a scale factor of 200.

3 Click the Advanced tab. In the r-direction scale factor edit field, type 200.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab. Type T in the Expression edit field on the Surface Data page.

3 Click OK.

4 From the Postprocessing menu, select Domain Plot Parameters.

5 Click the Line/Extrusion tab and select Boundary 1.

6 In the Expression edit field, type xA_mean.

7 In the x-axis data area, select the option button next to the Expression button, then 
click the Expression button. Type z in the Expression edit field, then click OK.

8 Click the Line Settings button.

9 Select Triangle from the Line marker list. Click OK.

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 BOUNDARY 4

Type Axial symmetry Temperatur
e

Convective flux Heat flux

q0 -alpha*(T-T0)

T0 T0
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10 Go to the General page and click the Title/Axis button. Click the option button next 
to the Title edit field and type Mean conversions in the edit field.

11 Click the option button next to the Second axis label edit field and type  
x<sub>A,mean</sub>, x<sub>B,mean</sub>, x<sub>C,mean</sub> 

in the edit field. Click OK.

12 Click Apply.

13 Return to the Domain Plot Parameters dialog box and select the Keep current plot 
check box.

14 Click the Line/Extrusion tab and type xB_mean in the Expression edit field.

15 Click the Line Settings button and select Square from the Line marker list.

16 Click OK then click Apply.

17 Type xC_mean in the Expression edit field.

18 Click the Line Settings button and select Circle from the Line marker list. Click OK.

19 Click OK to close the Domain Plot Parameters dialog box and generate the third 
graph.

20 In the figure window, click the Edit Plot toolbar button. In the Edit Plot dialog box, 
for each line, in turn, select the Show legend check box and edit the entry in the 
Legends edit field. When done, click OK.

P A R A M E T R I C  S T U D Y

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Parametric.

3 Type T0 in the Parameter name edit field and 625 626 627 628 629 in the 
Parameter values edit field.

4 Click OK.

5 Click the Solve button on the Main toolbar.

6 From the Postprocessing menu, select Cross-Section Plot Parameters.

7 Click the Line/Extrusion tab and type T-T0 in the Expression edit field.

8 In the x-axis data area, select the option button next to the Expression button, then 
click the Expression button. Type r in the Expression edit field, select mm from the 
Unit list and click OK.
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9 In the Cross-section line data area, type in the following values:

10 Click the Line Settings button.

11 Select Cycle from the Line marker list and select the Legend check box. Click OK.

12 Click OK to create the plot in Figure 5.

Finally, perform the following steps to produce Figure 6.

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the Line/Extrusion tab, type T-T0 in the Expression edit field.

3 Click the Line Settings button and select Cycle from both the Line color and the Line 

marker list. Select the Legend check box, then click OK.

4 Go to the General page and click the Title/Axis button.

5 Type Centerline temperature in the Title edit field and select the Auto option 
button for the Second axis label. Click OK.

6 From the Plot in list, select New figure.

7 Click OK.

R0 R1 Z0 Z1

0 0.0127 0.6 0.6
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