Abstract: In many groundwater studies, the areal extent of an aquifer is much larger than its thickness so that flow and transport take place primarily in horizontal directions. Also, using two-dimensional models saves computational time and requires fewer parameters than full-thr三维 dimensional modeling. Thus, the most common type of modeling in practical applications is two-dimensional involving vertically averaged dependent variables, primarily hydraulic head and solute concentration. This is a tutorial on depth-averaged groundwater modeling using COMSOL Multiphysics, primarily the Earth Science Module, with tips for avoiding some bumps on the road. We describe how to use COMSOL Multiphysics to solve problems involving, among others, regional flow, and pumping wells of infinitesimal and finite radius.

Keywords: Groundwater, Flow, Transport.

1. Introduction

Practical hydrologic and environmental applications often involve modeling groundwater flow and solute or heat transport in geologic formations that are nearly horizontal thin layers. Flow in such formations is essentially two-dimensional and, under certain conditions, can be modeled using analytical and semi-analytical methods, such as potential-flow theory for steady-flow problems, for example see . Transport problems are often treated as also two-dimensional, but this approximation is cruder because solute concentration is usually much more variable in the vertical direction than hydraulic head. Nevertheless, modeling of two-dimensional flow and transport is valuable in practical applications and one can find many examples in the literature, e.g., .

This paper is a tutorial to help professionals and students who want to use COMSOL Multiphysics, particularly the Earth Science Module, to solve some practical groundwater flow problems. COMSOL Multiphysics, and numerical methods in general, have advantages for problems with complex geometric features (boundaries and internal features like streams or lakes), heterogeneous properties, and nonlinear governing equations. However, practitioners may hesitate to make the transition due to numerous minor obstacles along the way. This paper is intended to facilitate the transition.

Note that model specific comments refer to version 3.4 of COMSOL Multiphysics. We focus on steady Darcy flow (low-Reynolds number flow in saturated media) with constant density.

2. Flow Modeling

2.1 General

The default implicit assumption in 2-D Darcy Law flow modeling in the Earth Science module is that a 2-D domain represents a 3-D domain with uniform properties and unit thickness in the third dimension. This applies for modeling certain problems in a vertical cross-section, such as on a plane perpendicular to the axis of a long dam.

For 2-D models that are obtained through depth integration, which is the most common case, some adjustments are in order. Instead of the saturated hydraulic conductivity \( K_s [m/s] \), one should use the transmissivity or transmissibility \( T [m^2/s] \). For a uniform confined uniform aquifer with thickness \( H \), \( T = K_s H \); for unconfined, it should be conductivity times saturated thickness (for a horizontal bottom, the saturated thickness equals the hydraulic head measured from the bottom of the aquifer \( T = K_s \phi \)). Instead of storage term \( S_s [1/m] \), one should use specific yield \( S_y [\%] \) for unconfined aquifers or storativity \( S [\%] \) for confined ones. Instead of liquid source \( Q_s [1/s] \), one should use the recharge term \( Q [m/s] \). In terms of results, the quantity termed in COMSOL as \( u_{esdl} \) should be interpreted as a depth-integrated specific discharge \( R_x [m^2/s] \). \( R_x \) is discharge in direction \( x \) for unit width in direction \( y \) over the depth of the aquifer.
For point sources and sinks: draw a point at the appropriate place. **Draw > Specify Object > Point;** then input the discharge, **Physics > Point Settings > Flux.** Input the discharge, which is \( [\text{m}^3/\text{s}] \) (do not use the discharge per saturated thickness, as implied by the units \( [\text{m}^3/\text{s}] \) next to the flux input box), with negative sign for extraction (denoting a sink) and positive for injection (denoting a source). Notice that output variables designated as “velocity” are actually depth-integrated discharges.

### 2.2 Example: Confined aquifer

Consider 2-D flow toward to well with extraction rate \( Q [\text{m}^3/\text{s}] \). The aquifer is horizontal, confined with thickness \( H \) \([\text{m}]\), uniform and isotropic with conductivity \( K \) \([\text{m}^2/\text{s}]\). Consider that there is a circular equipotential (fixed-head boundary) with radius \( R \) \([\text{m}]\) where the hydraulic head is \( \phi_0 \) \([\text{m}]\). The analytical solution is well known in terms of the discharge potential

\[
\Phi = \frac{Q}{4\pi} \ln \left( \frac{x^2 + y^2}{R^2} \right) + \phi_0
\]

and since for confined aquifer \( \Phi = kH \phi \), the solution in terms of the hydraulic head is

\[
\phi = \frac{Q}{4\pi kH} \ln \left( \frac{x^2 + y^2}{R^2} \right) + \phi_0
\]

As a separate case, consider that there is no well but we have recharge \( N \) \([\text{m}^3/\text{s}]\). Then,

\[
\Phi = \frac{N}{4} (R^2 - x^2 - y^2) + \phi_0
\]

which, in terms of the hydraulic head gives:

\[
\phi = \frac{N}{4kH} (R^2 - x^2 - y^2) + \phi_0
\]

These results were well reproduced by COMSOL for the data:

\[
H = 10 [\text{m}] \, , \, K = 10^{-5} \text{m/s} \, , \, \phi_0 = 20 \text{m} \, , \\
R = 40 \text{m} \, , \, Q = 10^{-3} \text{m}^3/\text{s} \, , \, N = 4 \times 10^{-3} \text{m/s}
\]

For the case of the well, the analytical and numerical results, plotted together, agree within millimeters. Of course, where the head is below \( H \) and the flow is unconfined, both solutions are wrong. (This can be fixed, as we will see later.) The agreement is even better for the case of the recharge.

### 2.3 Example: Unconfined Aquifer

We consider effectively horizontal flow (Dupuit-Forchheimer flow, see ). We maintain the same geometry and parameters as the preceding example but the flow is unconfined, i.e., the flow is between a horizontal impermeable layer at the bottom and the water table where pressure is atmospheric at the top. The relation between the discharge potential \( \Phi \) and the hydraulic head \( \phi \) is

\[
\Phi = \frac{1}{2} k \phi^2 
\]

\[
\phi = \sqrt{\frac{2\Phi}{k}}
\]

Then, for the case of the well, the analytical solutions is

\[
\phi = \sqrt{\frac{Q}{2\pi k} \ln \left( \frac{x^2 + y^2}{R^2} \right)} + \phi_0
\]

For the case of uniform recharge,

\[
\phi = \sqrt{\frac{N}{2k} (R^2 - x^2 - y^2)} + \phi_0
\]

In COMSOL, we must specify as transmissivity \( T = K \phi \), which makes the problem nonlinear. This may cause some numerical difficulties. For the case of point sinks, a negative head would lead to negative transmissivity that not only is physically meaningless but also prevents convergence. Thus, more than in the confined case, one must pay attention to the finite size of the well. The ad hoc way to handle the finite size of the well is to specify a grid size near the well point that is representative of the well size. Use **Mesh > Free Mesh Parameters** and specify the maximum element size at the point that represents the extraction well, the higher the computed value of the head at the well point. Thus, negative head can be avoided.

The nonlinearity of the problem necessitates iterations even for steady flow problems. Go to **Physics > Subdomain Setting > Init** and specify \( H(t_0) \) with the value for \( \phi_0 \) or some other reasonable value. Go to **Solve > Solver Manager** and check the first button **Init**
2.4 Example: Combined Confined/Unconfined Case

The flow may be confined in parts of the aquifer and unconfined elsewhere (such as near an extraction well where the head drops). This case can be handled in COMSOL by specifying appropriately, using logical operators, the transmissivity and solving iteratively, as for the unconfined case. For example, if the conductivity is denoted by $K$, the thickness of the confining layer by $H$, and the head by $H_{esdl}$, input instead of hydraulic conductivity the expression for transmissivity:

$$K*(H*(H_{esdl}>H)+H_{esdl}*(H_{esdl}<H)).$$

After a couple of iterations, the agreement with the analytical solution was found to be excellent.

2.5 Finite-Well Size

One can handle within COMSOL finite-size wells quite accurately. The well boundary is drawn and treated as one with a prescribed constant head; then, the flux (discharge) through this boundary is computed. The basic idea is that the head in the well is then adjusted to achieve the right value of discharge (consistent with the well pumping rate which can be positive, negative, or zero). This obviously can be done in a manual way, which is labor-intensive; it can also be done automatically as we will describe next.

Consider, for example, a circular well of finite size, with radius $r_w$ and center at $(0,0)$ The well extraction rate is $Q$. Let $H_{esdl}$ be the head and $u_{esdl}$ and $v_{esdl}$ be the depth integrated discharges in the x and y directions. The discharge through the boundary (let us consider it positive if outflow, i.e., from the well to the aquifer) is denoted $OUT$. It is computed through an integral of flux over the boundary. Then, we write the storage equation for the well: rate of change of water volume in well equals net discharge. This storage equation is an ODE on the head value at the well boundary. We can combine it with the PDE over the domain.

Here is the procedure in COMSOL. Consider that the head at the well boundary is denoted $wl$.

At Options > Integration Coupling Variables > Boundary Variables, highlight boundaries, Name: $OUT$, Expression $(u_{esdl}*x+v_{esdl}*y)/r_w$.

Then, at Physics > Global Equations, define state name: $wl$, equation: $Out+Q+\pi*r_w^2*wlt$. Set some reasonable initial value for $wl$.

Finally, at Physics>Properties, set weak constraints to Non-Ideal. Then make a mesh and solve.

After you compute the solution, it is a good idea to verify that the flux through the well boundary is the same as the pumping rate.

Of course, this method of modeling works for any well shape (just by changing the way of computing $OUT$ in order to conform to the geometry) and it can be used for ponds or lakes that are hydraulically connected to the aquifer and have constant but unknown head. Also, an even more accurate solution could be obtained by computing the boundary flux through the Lagrange multiplier method.

2.6 Thin Elements

One of the challenges in numerical modeling is the representation of important processes that take place in thin objects or on boundaries. Example include thin impermeable objects (like sheet piles) or thin highly permeable objects (like drainage ditches). The actual volume occupied by these objects is orders of magnitude smaller than the volume of the domain so that gridding them as 2-D objects with the rest of the domain is not practical. However, COMSOL allows one to model such elements as one-dimensional using COMSOL Multiphysics > PDE Modes > Weak Form, Boundary. This interesting and important issue will be explored in another paper.

3. Transport Modeling

We refer to Application Modes > Earth Science Module > Solute Transport > Saturated Porous Medium > Transient Analysis. Depth-integrated 2-D modeling can
be applied in COMSOL as follows: Instead of pore-volume fraction (porosity), use porosity times thickness, instead of “velocity”, use depth-integrated discharge.

It is important to note that, if recharge terms (including point sources or sinks) are included, go to Physics>Properties, and then select "Conservative".

4. Conclusions

COMSOL Multiphysics is an excellent tool for solving flow and transport problems in thin layers where the domain is represented as two-dimensional domain and variables are defined through integration over the depth of flow. I hope that this tutorial will help users.

5. References


6. Acknowledgements

Work was partially supported by NSF under grant “Non-equilibrium transport and transport-controlled reactions”.