Discussion Closed This discussion was created more than 6 months ago and has been closed. To start a new discussion with a link back to this one, click here.

Error: dependent variables are not coupled to all degrees of freedoms in the model

Lawrence Renna

Please login with a confirmed email address before reporting spam

Hello!

I am trying to run the following model, but keep getting an error:

"The following dependent variables are not coupled to all degrees of freedoms in the model: comp1.cPAHx, comp1.cPAx. - Domain: 1"

Are there typical reasons for this type of error?

Thank you in advance for any help you can provide!

Lawrence



2 Replies Last Post Oct 20, 2017, 7:54 PM EDT

Please login with a confirmed email address before reporting spam

Posted: 8 months ago Oct 20, 2017, 12:14 PM EDT

I have the same issue! But on a few boundaries rather than a domain. (Sorry for making you think someone had answered your question)

I have the same issue! But on a few boundaries rather than a domain. (Sorry for making you think someone had answered your question)

Lawrence Renna

Please login with a confirmed email address before reporting spam

Posted: 8 months ago Oct 20, 2017, 7:54 PM EDT

i did fix this problem. i named my variable with a lowercase x. for example i had defined two dependent variables: cA and cAx. This caused rhe error

i did fix this problem. i named my variable with a lowercase x. for example i had defined two dependent variables: cA and cAx. This caused rhe error

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.