An Issue on a quite simple model while doing Time Dependent Analysis by using LMS and MBD

Please login with a confirmed email address before reporting spam

Hello,

This is a very simple model with only one block actually. But I have been struggling on this for quite a while.

When I disabled the Damper C1, it can pass the test. However, with the damper actived it showed an Error:

  • Feature: Time-Dependent Solver 1 (sol1/t1) Repeated error test failures. May have reached a singularity. Time : 0 Last time step is not converged.

Can anyone help me on this? The two models with my idea is as attached. Thank you in advance.



3 Replies Last Post Aug 23, 2019, 7:40 AM EDT
Pawan Soami COMSOL Employee

Please login with a confirmed email address before reporting spam

Posted: 4 weeks ago Aug 22, 2019, 2:29 AM EDT

Dear Leon,

Try using Velocity node instead of Displacement node to prescribe the motion when you have a damper in parallel to a spring. This should resolve the problem.

Best regards,
Pawan Soami

Dear Leon, Try using Velocity node instead of Displacement node to prescribe the motion when you have a damper in parallel to a spring. This should resolve the problem. Best regards, Pawan Soami

Please login with a confirmed email address before reporting spam

Posted: 4 weeks ago Aug 22, 2019, 6:51 AM EDT

Dear Pawan,

Thank your response and the support!

Best wishes, Leon

Dear Pawan, Thank your response and the support! Best wishes, Leon

Please login with a confirmed email address before reporting spam

Posted: 3 weeks ago Aug 23, 2019, 7:40 AM EDT

Dear Leon,

Try using Velocity node instead of Displacement node to prescribe the motion when you have a damper in parallel to a spring. This should resolve the problem.

Best regards,
Pawan Soami

With the Velocity node instead of Displacement node, it works in the ‘Time Dependant Study’, but it does not work for the 'Eigenfrequency Study':

  • Feature: Eigenvalue Solver 1 (sol2/e1) Singular matrix.
  • Detail: There are 1 void equations (empty rows in matrix) for the variable comp1.lms.vel1_p1_u. at coordinates: (0,0,0), ...
>Dear Leon, > >Try using Velocity node instead of Displacement node to prescribe the motion when you have a damper in parallel to a spring. This should resolve the problem. > >Best regards, >Pawan Soami With the Velocity node instead of Displacement node, it works in the ‘Time Dependant Study’, but it does not work for the 'Eigenfrequency Study': - Feature: Eigenvalue Solver 1 (sol2/e1) Singular matrix. - Detail: There are 1 void equations (empty rows in matrix) for the variable comp1.lms.vel1_p1_u. at coordinates: (0,0,0), ...

Reply

Please read the discussion forum rules before posting.

Please log in to post a reply.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.