Note: This discussion is about an older version of the COMSOL Multiphysics® software. The information provided may be out of date.

Discussion Closed This discussion was created more than 6 months ago and has been closed. To start a new discussion with a link back to this one, click here.

Using the assembly form

Hello,


I am trying to simulate with "piezolectric devices". Specifically, I would like to exert stress on a thin film in contact with a piezoelectric 3D block. The geometry is quite simple but in order to mesh the thin film using "swept" I have to use "assembly" finish form (if I am right).

The problem is that during the simulation, it seems that both 3D piezoelectric block and thin film does not interact in any way (i.e. stress is not exerted).

I have played with "contact pairs" and "indetity pairs" with no success ! I am getting desesperate.

Any suggestion ?


Thanks !

Javier.

0 Replies Last Post May 6, 2013, 9:28 AM EDT
COMSOL Moderator

Hello Javier Martin

Your Discussion has gone 30 days without a reply. If you still need help with COMSOL and have an on-subscription license, please visit our Support Center for help.

If you do not hold an on-subscription license, you may find an answer in another Discussion or in the Knowledge Base.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.