Applies to: COMSOL Multiphysics®, Design Module Versions: All versions

Problem Description

For users of a floating-network license for COMSOL Multiphysics that includes the Design Module, a license key for the Design Module is checked out as soon as you draw something in a 2D geometry. This is the case even if you have not used any of the functionality for adding dimensions and constraints, which requires a license for the Design Module.

Solution

To make the COMSOL software only check out a license for the Design Module when a user adds a constraint or dimension feature, we recommend installing the provided hotfix.

For Windows®, follow these steps:

  • Make sure that you have the latest version 5.5 Update 3 (Build 359) installed. Start COMSOL 5.5 Update 3. On the File menu, choose Help and then click About COMSOL Multiphysics. Verify that the version is 5.5 and that the build is 359.
  • Download the file comsol_5.5.0.359_win.exe (see the links below).
  • Double-click the downloaded executable in order to launch the installer and click Next in order to start the installation.
  • On the Select Destination Folder tab, specify your current COMSOL installation directory, e.g. C:\Program Files\COMSOL\COMSOL55\Multiphysics or C:\Program Files\COMSOL\COMSOL55\Server. Click Next.
  • Click Install and Close.

For Linux®, follow these steps:

  • Make sure that you have the latest version 5.5 Update 3 (Build 359) installed. Start COMSOL 5.5 Update 3. On the Help menu, click About COMSOL Multiphysics. Verify that the version is 5.5 and that the build is 359.
  • Download the file comsol_5.5.0.359_lnx.tar.gz (see the links below).
  • Start a terminal prompt.
  • Connect to your installation directory, for example, /usr/local/comsol55/multiphysics:
    cd /usr/local/comsol55/multiphysics
  • Extract the downloaded file:
    tar xzf {download path}/comsol_5.5.0.359_lnx.tar.gz
  • When you have applied the hotfix, start COMSOL 5.5 Update 3. Open Preferences from the Options menu. Under Geometry, clear the In new models check box.

For macOS, follow these steps:


Note: please follow the instructions below exactly. Do not attempt to copy the folders in the ZIP archive to the installation as that might lead to a invalid installation.


  • Make sure that you have the latest version 5.5 Update 3 (Build 359) installed. Start COMSOL 5.5 Update 3. On the COMSOL Multiphysics menu, click About COMSOL Multiphysics. Verify that the version is 5.5 and that the build is 359.
  • Right-click on comsol_5.5.0.359_mac.zip (see the link below) and select Download Linked File.
  • Launch the Terminal Application.
  • Connect to your installation directory, for example, /Applications/COMSOL55/Multiphysics:
    cd /Applications/COMSOL55/Multiphysics
  • Extract the downloaded file:
    unzip {download path}/comsol_5.5.0.359_mac.zip
    In response to the prompt to Replace files, type A and press return. (If you do not get a prompt about replacing files, it is likely that you connected to the wrong directory.)
  • When you have applied the hotfix, start COMSOL 5.5 Update 3. Open Preferences from the COMSOL Multiphysics menu. Under Geometry, clear the In new models check box.