Applies to: COMSOL Multiphysics® Versions: 5.5

Problem Description

When trying to start the license manager for COMSOL Multiphysics 5.5 on my Linux computer, I receive the following error message:

LMCOMSOL: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by LMCOMSOL)

Solution

The underlying issue here is that you are using a Linux distribution that is too old according to the COMSOL Multiphysics System Requirements

In the first update to COMSOL Multiphysics 5.5, binaries for the license manager was included that supports older versions of Linux distributions. If you use the binaries distributed with COMSOL Multiphysics 5.5 update 1, it should work to run the license manager on Debian 6 and newer, RHEL/CentOS 6 and newer, and SLES 11.4 and newer.